Https not showing padlock


I have done a bit of researching into why a client’s site would not be showing the https padlock even though all of the links have https in them. I have downloaded the WP Migrate DB plugin plugin recommended on a different thread, and it ran successfully run it, however it hasn’t made a difference to the visibility of the padlock - are you able to help please?

Many kind regards,

Hey Bethany,

Please install the Better Search Replace plugin then do the following:

    search for and replace it with and
    search for http:\/\/ and replace it with https:\/\/

Hope this helps.


Thank you for your help - I completed the search and replace, but it’s still not showing a padlock?

Hi Bethany,

Did you untick the Run as dry option when you did a search and replace?

If you did but the issue persists, please provide us with the admin access to your site in a Secure Note:


Yes, I did a dry run, and then unticked and ran again - and the issue is still unresolved.

Yes please, if you would be able to log in I’d really appreciate it.

Thank you.

Hi Bethany,

I have check and found out that there are assets (video and images) though https when I checked on Media Library is still causing Mixed content. See this:
Can you try to reupload those images and then use the new uploaded one on the content. This will make sure it is now https. Hope this helps.

Thank you - I am making my way through updating all of the images - however, now I am updating images, the header has messed up… What is going on? I change one thing and something else goes absolutely awol…

Hello Bethany,

I have compared your homepage header and the actual header in the editor. It seems that the homepage is not displaying the correct header. Do you have any caching plugin or does your server has caching mechanism like varnish? After doing the updates or site changes, always remember to clear all caches (if you are using WP Rocket, WP SuperCache or W3 Total Cache) when updating so that the code from the latest release is always in use. This will help you to avoid any potential errors.

And please clear your browser cache too. You may use private browsing mode in testing your site to make sure that you are viewing the latest codes from the updates and not the cached version in your browser.

Please let us know how it goes.

As far as I can see, there wasn’t a caching plugin and I had cleared browsing cache to double check the view.

I think it’s the similar glitch that my footer had, but I don’t know why changing an image on a page would distort the header. When I am in the editor it views correctly, but if I am in the editor and a preview of the header shows up, it shows the distorted view. Please see attached image…

Hey Bethany,

I’d first like point out that you do have a caching plugin installed.

I cleared the cache and deactivated the caching plugin but the issue persisted. The Header Builder’s Styles fail to load in the front-end. That usually is caused by broken CSS code added somewhere within the builder’s interface but I saw none in this case so this means that something is wrong with your web host and/or WordPress setup. With that said, please also give us FTP access.

Regarding your SSL setup also, since you did a search and replace, all images within the builder are now in HTTPS. However, resources in your site aren’t redirected to HTTPS still. For example, you can load the image in the secure note in HTTP. It should be redirecting to HTTPS. You will need to contact your web host regarding this if it’s part of their service to assist converting sites to HTTPS. If not, you need to consult with a third-party developer.


There is now a caching plug in yes, but as I said, at the time there wasn’t one. I have subsequently installed one.

Okay, I will contact my host with your suggestions above.

Thanks for clarifying and checking with your host.

Just hope we can get to the bottom of it soon. I think they’re going re-install WordPress and see if that helps.

Will send FTP log in…

My web developer / host has re-installed Wordpress but the issue remains and he thinks it’s got to be with the theme itself…?

Please do let me know how you get on with the FTP log in.


Hey Bethany,

I’ve successfully logged in to your server but I saw no error logs. I tried enabling WP Debug and still your server doesn’t generate error logs so I temporarily installed a server info plugin and found that your site’s on a Windows NT server. Though WordPress can run on Windows server, it is not recommended and it might not support or may not work well with technologies used in our builders.

I also tried increasing the WP Memory but it also has no effect. Because there’s no error log, we can’t track the exact cause of the problem. It’s only your web host who can do this since they have full access to the server.

Please contact your web host if they can migrate your site to a Linux / Unix based server and then test your site again. If they don’t support Linux, it would be best to try a Linux based web host.

Thank you for understanding.

We had formatting issues with the footers and you guys helpfully changed/added some code and it fixed the formatting, do you think the header needs additional coding?

Rad, Staff, 5d

Hi Bethany,

This kind of weird, the flex styling for the footer is not being generated, this is my first time seeing this. I went ahead and added this CSS to your footer bar’s CSS.

$el.x-bar-content {
flex-direction: column;
align-items: center;

Hi Bethany,

Please ignore the header issue if you did not do anything to broke it, that could be just a side effect of your bigger issue which I suggest that we focus on. And reuploading all your images URL manually is not efficient.

And I can not replicate that header issue on my end, so it could be just a caching related. And I dont think you need a custom CSS for that simple header.

These is your real issue

As you can see even if we are accessing your site in a live URL it still requests resources from your development URL this means the migration method you’ve done did not go through successfully. So you need to correct that first, you can follow the database migration method provided here.

And please keep in mind as well the correct URL before when you’re still developing the site because your site is accessible via secure (https) and non-secure (http) in both staging and live URL, this is a quite a dilemma now.

I think, since on your Settings > General the WordPress Address (URL) and Site Address (URL) is, you develop the site using that URL.

So on your migration method, it should be from to

If you’re not comfortable doing this, please contact your developer or hire someone that is knowledgeable in Wordpress site migration.

Let us know how it,

Thanks - it was strangely on the wrong IP address, so thankfully the issues have now been sorted as it’s back on a Linux based server.

Thank you to everyone who has made an effort to try and resolve. It really is much appreciated!

You are most welcome, Bethany. :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.