How to remove extra white space below footer

Please help, I need to figure out how to remove the white space

Hi Devin,

The white space is your Footer Widgets area. You can deactivate it in Theme Options > Footer

For your reference, you can checkout our Knowledge base


Thank you, but when I did that, it got rid of my whole footer. There’s white space underneath that with the text " assign a menu " and " powered by x theme " that I’d like to remove.

Also, on a separate site, the text on the footer menu won’t show up. I can highlight the text and see that it’s there that way but when it’s not highlighted it’s blended in with the background.

Hi Devin,

To remove your footer, you can turn off Bottom Footer as shown in the screenshot

For your footer menu, you can change it’s color by adding the code below in Theme Options > CSS

.x-colophon.bottom .x-nav li a {
.x-colophon.bottom .x-nav li a:hover {

Here are some related links for further reading:

Intro to CSS -
How to get CSS selectors -
Get Started With Viewing And Changing CSS -


Hi. Sorry if I’m not being clear enough, but I’m trying to remove an area below the footer unless I’m referring to it wrong. I attached a screenshot to give you a better understanding of what I’m talking about. I didn’t screenshot the whole footer for privacy purposes

Also, when adding the code for the second website, it changed the color of the text in the white area that I mentioned in the first issue but not on the text for the different menus that I’ve created. Here’s another screenshot. It changed the text " assign a menu " to black but for the other text that I have highlighted, it only shows up when highlighted.

Hi Devin,

Please provide us login credentials in a secure note so we can take a closer look, and provide a screenshot of the white space that you’re referring so we can have a better idea, you can put it on the secure note too.


Hi Devin,

Thank you for the credentials, but not sure why you give 2 credentials where you only have 1 site with X.

Anyways, lets make this clear first so we understand each other.

That is your footer, the red area there is called Footer Widget Areas the blue part is called Bottom Footer.

You can turn off Bottom Footer option under Theme Options > Footer

That should solve your first issue (extra white space).

Your second issue is your Footer Widget Area text blends with the white background. So you have 2 options to solve that, first is to change the text color.

/*footer widget text color*/
footer .h-widget,
footer .widget {
	color: #333;

Or change the Footer Widget Area background color

/*footer widget areas background-color*/ {
	background-color: #333;

Take your pick.

You can add custom CSS under Theme Options > CSS

Hope that shed some lights,

Oh, wow. I’m ashamed at how easy of a fix the first issue was. Thank you so much. As for the second issue, the code did the trick. Again, thank you. Also, I’m not sure what you mean? both themes have X, but only one is licensed at the moment.

I appreciate your patience with me, btw.

EDIT: One last thing, is there a way I can remove the little arrow next to my widgets? Not sure if this is a newer feature with X, but when I created my widgets last year on my first site, they never had the arrows beside them.

Hi Devin,

We are confused because you provided two logins which means you have two sites but I checked in your license page and you have only one site registered.

To remove the arrows, you can add the code below in Theme Options > CSS

.h-widget:before {

Hope that helps

Sorry, didn’t mean to confuse you guys. The code worked, btw. Thank you.

Glad we could help.


Thank you for your guys’ help, but now I have to revisit this question because of a similar issue with the text color not showing up in my footers widget area.

The code seemed to work for the first widget but when I went to make another one, the text didn’t show up again. Here’s a screenshot.

I have four links under the menu widget, but they unfortunately only appear when highlighted.

I’m trying to keep coding my site down to a minimum, but if there is no other way to change this issue, then I’ll have no choice.

Hi Devin,

That is because those are links (also white by default) not text. Unfortunately, there is no option for those to change on Theme Options. You need to use this CSS to change those links color.

footer .widget ul li a,
footer .widget ol li a {
	color: #000;

Hope it helps,

Okay, no problem. The code worked again. Thank you.

You’re welcome.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.