How to disable comments?

Didnt find anywhere the setting to disable the comments…

Hey Jimi,

There is no feature in the theme to disable comments. It’s actually a general WordPress area.

You can use a plugin like Disable Comments or you can follow this third party guide:

Hope that helps.

Installed that plugin, allthough it is not tested with this wordpress since it s updated last time a year ago :slight_smile: but it works so problem solved. Thank you

Glad we were able to help :slight_smile:

I installed that plugin, and it is working, but now I am seeing this error message:

Notice: Undefined index: WP_Widget_Recent_Comments in /home/toast2/public_html/wp-content/themes/x/framework/functions/setup.php on line 213

Pls advise. Thanks!

Hey @sc8tty,

You are seeing a PHP notice. You can get rid of the notices by disabling the debug mode. You can do this by opening wp-config.php and adding

define('WP_DEBUG', false);

/* That's all, stop editing! Happy blogging. */

When you revisit the page, you should no longer be seeing the notices.

Please let us know if this works out for you.

Wouldn’t it be better to disable the widget and keep the debug mode active?

Hey @sc8tty,

Yes disabling the Comment widget would work too. Eventually, you will also have to disable the debug mode. Turning the debug mode ON is only good if you are debugging your site. Normal WordPress installation have it turned OFF by the way.

Hope this helps.

Ah I see. Thanks.

You are most welcome!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.