Header Will Not Deploy

Hello Joshua,

I have checked your header and there are no bar elements on the fixed sidebar.

What this means is that you are referring to the default fixed sidebar of the icon stack. When you go to Appearance > Sidebars, I can see that you have created bbPress and Homepage sidebar. If you have assigned the sidebar to a page, post, taxonomy or post type, the sidebar then that is where the sidebar will only display. By default, the Main Sidebar will be visible if there are no assigned sidebar.

Hope this helps.

Thank you for checking it out. However, the sidebar is not what I am talking about. I am talking about the header layout. I mentioned that I reverted everything back when that side header never populated. Then I ran into that issue where:

I apologize I never gave example links for you. Here is an example image of the header not populating and, instead, a widget place is populating - https://prnt.sc/1f1k2rr

Here is a page that I mentioned belonged to a category for that side header but never populated - https://prnt.sc/1f1luct

Here are some example links:

  1. https://www.tips4gamers.com/little-big-snake-tips-tricks-and-cheats-complete-guide/
  2. https://www.tips4gamers.com/how-to-trade-for-rookies-in-madden-21-franchise-mode/

The header in the Madden page needs to be the universal header, which is assigned to the entire site when looking into theme options > headers > Main Dark Header Layout.

This is not the case and no matter what I do it will not display on any pages besides Madden. This happened before but I deleted that old header and redid another and it worked.


Hello Joshua,

Please do the following:
1.) Temporarily deactivate Cloudflare and WP Rocket plugin
2.) Go to Pro > Settings > System and click the " Clear Style Cache" button.
3.) Logout of WordPress or use private browsing mode and test the page again.

By the way, I am not logged in and the header is displaying on my browser:

Best Regards.


I have actually already done that. I did it again for good measure and nothing has changed. If you type in https://www.tips4gamers.com/?nocache you will see the header disappear in incognito mode or not.

What could be causing this if it is not related to caching or a plugin? Right now I all of my plugins are deactivated, I paused Cloudflare, cleared the system cache, my browser cache, and Cloudflare cache, and nothing has changed.

UPDATE: You can also see that https://www.tips4gamers.com/how-to-trade-for-rookies-in-madden-21-franchise-mode/?nocache changes nothing for that URL or https://www.tips4gamers.com/little-big-snake-tips-tricks-and-cheats-complete-guide/?nocache changes nothing for that URL. It’s strange.

But if I create a brand new header (which I really don’t want to as it takes quite a bit of time), it will be fine.

To be a lot more specific, what I did was create a brand new header and appoint it to the right side of the page. This header is supposed to act as a menu for Madden specifically for larger screens like desktops and laptops. I then assigned it to the Madden 21 Guides category but it didn’t go through. This is when the Main Dark Header Layout (formerly Dark Header Layout) disappeared from every page but that category. I then added a condition to the Main Dark Header Layout for entire site and the category Madden 21 Guides. I then deleted the header assigned to the right side and the Main Dark Header Layout still didn’t show up. I change the name of Dark Header Layout to Main Dark Header Layout to see if it would change but nothing changed.

Thanks and regards

Since I cleared the cache there is no need to append ?nocache as the header is gone now.

Hi Joshua,

How many times did you rename the header? There could be a conflict between the header names and header metadata. Please save the current header as a template, unassign the current header and create a new header with a different new name. Assign the new header as the header of the entire site and test again.

Please do not forget to clear all the plugin caches before testing again.

Kindly let us know how it goes.

Thank you for that information and your help. I just deleted the header then created a brand new header and assigned it to entire site and I have no header.

I cleared all of my cache (Cloudflare, WP Rocket, Browser, and SiteGround) and there was no difference.

There is no header present on any page now and the brand new header I just created is not populating on any page.

UPDATE: I forgot to mention I also cleared the system cache from Pro > Settings > System.

What do I do from here?

Also, I only renamed the header once.

Does it have anything to do with the new WordPress 5.8 update? As in compatibility?

Hello Joshua,

I have created a new header and set it as the header for the entire site. Both the given URLs were no longer displaying any header at all. The new header is not displaying either. Can you please leave the Cloudflare and WP Rocket plugins deactivated so that we can try to assign another header and see if the new assignment will work?

Please let us know if you give us permission to do so. Thanks.

I have put Cloudflare in Development Mode to bypass Cloudflare’s cache and I deactivated WP Rocket. You have permission to continue your investigation!

Thank you for helping out.

Hello Joshua,

We still haven’t figured out the cause of the issue. We even removed the condition in your header allowing the default header to display. Nothing is displaying even the default header. Please give us permission to put your site under construction mode so that we can proceed with switching to the parent theme and temporarily disable all the active plugins instead.

Thank you in advance.

That’s so strange. Go ahead and do whatever is necessary to find out more about what’s going on.

Just so you’re aware, Cloudflare/WPRocket will bypass the cache for logged in users so you should not be affected by any cached pages. The response headers should state bypass.

However, if you want to, you could toggle Development Mode on via the Cloudflare plugin. If you cannot access the plugin’s settings then let me know and I will do it. It only has a span of 3 hours before it is automatically reenabled, and I am not sure when you’re investigating it so I’ll keep an eye out for a response.

Also, I cannot completely disconnect from Cloudflare as they serve my Origin SSL and Edge SSL. We are on the HSTS preload list so the site wouldn’t work at all.

Hello Joshua,

Could really be a caching related issue, I was able to assign that Main Dark Theme Header to entire site with no issue.

Hope it helps,

1 Like

Hi Friech,

Thank you! What a relief. I am just a bit confused on how it was a caching issue but it worked so that is all that matters.

The reason I am confused is that we bypassed Cloudflare’s cache and WP Rocket was disabled. All of the cache was then cleared and even when looking at the site with cache disabled (example.com/?nocache) it still didn’t resolve itself.

Would there be a specific reason for that? The only thing I can think of is the Browser Cache TTL, which is set to 4 hours but it was still caching the pages for a few days for some reason?

Would you mind elaborating on the caching issue for me please so I can avoid such issues in the future?

Thanks and regards,


Hi Josh,

I did not get really have the chance to troubleshoot the issue as it works fine when I set Main Dark Theme Header the first time.

I assume you only bypassed Cloudflare’s cache and disabled WP Rocket but did not Purge the cache of both.


1 Like

I did purge both but maybe it was just a timing issue. Or maybe you’re just good luck.

Thanks for the help. Take care.

Yup, it could be the timing.

Please write us a separate thread if that issue with “side header never populated on the select posts” persists.

Have a nice day,

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.