G-ZIP Help - Followed Performance Section


I followed the manual process to g-zip via your performance guide. Added the code in ht access.

The issue now is, when doing a GT mertric website scan…

I’m still getting these fules which aren’t g-zipped

Hi @Jord56,

Thanks for writing in! it seems that your gzip is not yet enabled. You may need to contact your hosting provider and ask them to enable it or at least ask them how you maybe can enabled the gzip compression.

Please let us know how it goes.

I don’t understand? g-zip works with w3 total cache when enabling it on the plugin. why do i have to go through an extra step in order to get g-zip to work doing it manually? i might as well use w3 total cache so i dont have to contact my host…

I also use cloudflare so is there a way to enable g-zip this way?

I’m want to avoid using g-zip on w3 total cache itself, but if i have to contact my hosting in order to enable this will just use w3 total cache…

Also, an update…

For some reason, when scanning with GTmetrics everything will be okay working as it should and other scans will show my g-zip not working…its weird…

Update, i just reverted back to w3 total cache and enabled g-zip this way because too much of a hassle too do it manually and having to contact my host…

Hey Jordan,

If Gzip only works if you use W3 Total Cache, it is right that you should use it instead of the manual htaccess method or rules because the creators of W3 Total Cache have more expertise with regards to website optimization such as enabling Gzip in different servers.

Our Performance guide is only a general guide. We have this disclaimer at the beginning of the article:

That means suggestions posted in there like the htaccess rules might not work in some hosts or servers and making it work for the specific server is outside the scope of our support. Please see our Terms.

I wish you understand our position regarding this matter.

Thank you.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.