Essential Grid custom links not working on Mobile

I am using Xtheme, Integrity stack, Chrome on Android

We are building our site to share videos by category using Essential Grid. This works fine on mobile using the maximum rows setting, but for the pages using custom links, such as this one:

The mobile display is completely broken:

The custom links work in that the pages can be navigated to, but they’re not legible at all. How can I make this grid work on mobile? Are custom links limited because of default image size? Please advise.


I went into my custom grid and changed it to a page-based grid and am having the exact same issue.

Hey Bill,

Thanks for detailing the issue. I checked your staging site and there’s a problem.

Once you have fixed that, we’d also need the URL of the page having the issue and WordPress admin access in a Secure Note so we could check the grid’s setup.


Oops sorry, I had changed the location of the staging site in settings so I could use Cornerstone and never changed it back. It should be working now. The page in question is:

That page is one example of the issue, but all the other pages using grids like it are also having problems, i.e. all the “hub” pages that lead to other posts in the “Video” section of our website.

Hi Bill,

It is a matter of the height and width which is getting too small. Please go to the Essential Grid Options in Question > Grid Settings > Columns and click the Advanced mode. There you will see options to set minimum width and height to avoid having the items getting too small.

Thank you.

1 Like

Thanks very much!

So I need to have the height higher than, say, 1? In order for it to display properly?

Hi Bill,

The 1 is still small for height and width. Let’s say you have 767px device and wish to display a 2 item in a row. The please set the height yo 767px / 2 = 383.5 (383 since there is no decimal in pixel unit).

You could change the minimum height around that number, or simply 200px just make sure it has noticeable dimension. 1px is just a dot :slight_smile:


Thanks. I tried changing the values around but have not been able to get the grids to display properly. I think this plugin just isn’t going to work for us.

I figured it out!

The padding is what was causing issues for these particular grids. The page in question had no container, so adding the padding made the images way too small on mobile. I removed the padding and now the grids are displaying just fine

That’s great! Glad to hear you’re all sorted, Bill!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.