Envira Gallery not centering

Hi guys, I am creating a page to display only images, I done in the past using media masonary grid via WPBakery Page Builder but I don’t like the white page border on the lightbox when the image is displayed.

I want to maybe give a try to Envira galery, I did a test but the images dont filled the page and it’s showing on the right. I need to be like this…

Can you help with that?

Hello @LucyKeile,

Thanks for writing in!

To center the grid, please make sure that you have enabled the Global Container in the row settings.

If nothing is helping, provide us access to your site so that we can check your settings. Please create a secure note with the following info:
– Link to your site
– WordPress Admin username / password

To know how to create a secure note, please check this out: https://theme.co/apex/forum/t/how-to-get-support/288


the global container is on.

Hey Lucy,

Sorry for the confusion. Going back to your opening message, you want the gallery to “fill” the page and the way I understand it, you want the gallery to span fullwidth of the page.

Enabling the Global Container will bound the gallery to a container so you can’t achieve fullwidth.

Here’s what to do:

  1. Turn off the Global Container in the Row. This will make the gallery span fullwidth.
  2. In you Gallery’s Configuration, set your desired rows and not Automatic. The reason for that is because you’ve shown a fixed number of columns in your sample/screenshot. Automatic will display a random number of columns. For more Envira Gallery usage instructions, please see https://theme.co/apex/forum/t/extension-envira-gallery/67
  3. To eliminate the white spaces, set the Column Gutter Width and Margin Below Each Image to 0. And, also set the Section’s Paddings to 0. You won’t see the Padding option if Advanced Mode of Cornerstone or Pro is disabled though so you need to enable that under the Preferences tab in the Settings.

Hope that helps.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.