Envira addons not installing


I have bought a license for the Envira Gallery and I get “There was an error installing the addon. Please try again.” every time I try to install one of the addons. I have reinstalled the plugin with both .zip upload and ftp unpacked method and still no go. What could be the problem here?



Please, check if there is any plugin conflict and to do that, disable all of the plugins and check if you can install it normally. If it did not work, try to check your PHP memory limit and increase it if is necessary following this article: https://docs.woocommerce.com/document/increasing-the-wordpress-memory-limit/

After deactivating plugins and increasing php memory limit I am still not able to install envira addons. :frowning:

Hi @Agenta,

I have tried to install plugin using X adds on also on your setup and it seems that the connection from servers to retrieve the addons list is blocked by your hosting service provider. Please check error log. Let’s see if there’s anything more substantial that will give us more information on the issue. Then, contact your hosting regarding this issue.

I suggest that you temporarily change your hosting service provider and Move Your Website to a temporary hosting or your local machine to fix the issue, After the installation of the addon you will be able to move the site back to your sever.

Let us know how it goes.


Ok, thanks. Will this mean the domain(name) provider or the actual server the site is on? This is on two different providers actually on this setup. I will contact the one that the issue is coming from.

Hi There,

I’m sorry for the confusion here. We’ve only included the Envira Gallery plugin bundled with X theme, so you cannot use their Addons. In case if you want to use their Addons, you will need to purchase a separate license from the plugin author.

For more information, please refer to our guide here (https://theme.co/apex/forum/t/extension-envira-gallery/67).


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.