Editor permissions


I’m trying to give editors the ability to insert ‘Classic Embedded Video’ but it just doesn’t appear in the list of elements: http://prntscr.com/nywouo
I tried to enable all classic elements for Editors and not all elements are there to insert: http://prntscr.com/nywnst

I’m using the latest version of Pro Theme.
Do you know what could cause this issue? Could you take a look at it?


Hey Carina,

I have just tried in my local setup and I was able to get the Classic Embedded Video permission for an Editor user and it works fine.

Would you mind double checking if you are logged in using an Editor user? Also, try unchecking all the fields for the Classic Embedded Video element then save the settings then enable it again.

If the issue persists, try testing for a plugin conflict. You can do this by deactivating all third party plugins, and seeing if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.

In case you are still not able to get the element display, please provide us with the admin access to your site in a Secure Note:

I already tested without any plugins enabled and turning options on and off.
I’m adding login credentials.

Hi @carinaa,

Thank you for the credentials.

I can see the issue. You have a multisite setup. To edit permission please use a super admin accounts. Thanks.

Hey @carinaa,

I just want to clarify that only Super Admins are allowed to embed iframes in a WordPress Mutlisite setup due to security reasons.

When posting third-party hosted videos in multisite, you can try using the WordPress oEmbed feature or shortcode added in a Text element instead. See https://wordpress.org/support/article/embeds/. But, to make it responsive, you need to wrap it with our Video Embed shortcode like this.



Hope that helps.

Thank you for the clarification!

You’re most welcome, Carina.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.