Duplicate title tags and meta descriptions

Hi, the problem is still there, how is this going to change title tags and meta descriptions on the pages mentioned?


Kindly refer to the link below

See Subpages With Duplicate Meta or Title Tags Section

Hope that helps.

Perfect! that fixed the problem, thank you!

Ok, so, after changing that, the single portfolio items are behaving strangely…

Normally, you click the top left (grid icon) and it takes you back to the main portfolio index page, its stopped working.

Hi logoglo,

Which option exactly did you change? I believe “Subpages With Duplicate Meta or Title Tags” in this guide, correct?
Can you confirm if you reverted this option back the Portfolio grid icon will work fine?

It could be another unrelated plugin conflict that is causing this issue, in this case I suggest doing a plugin conflict test, the safest way to do that is to install “Health Check” plugin and enable “Troubleshooting mode” if everything went okay, then you can re-enable plugins one by one to figure out the culprit. The good thing about “Heath Check” plugin is that it’s developed by WordPress team and it only affects your logged in session so that other visitors won’t be affected.


I reverted, and its still having the issue. I disabled all plugins, and it still does it.

Hey There,

I can see that you are using WP Rocket plugin. Please clear your plugin cache before testing your site. To better assist you, would you mind providing us access again to your site so that we can check it?

Thank you.

Hi cleared the cache when I tested it. Login in secure note.

Hey There,

I have logged in and it seems that your SQL server is down.

The error occurred because the portfolio items were not assigned to a parent page. Please edit each of the portfolio items, find the “Portfolio Item Settings” and assign the Portfolio Parent to default or a specific page.

If set to default, just make sure that you have created a page that is using the Layout - Portfolio page template. Please check out this knowledge base articles:
https://theme.co/apex/forum/t/meta-options-portfolio-items/145/1, https://theme.co/apex/forum/t/features-page-templates/50/1

If being set to default and you do not have a page that uses the Layout - Portfolio page template or simply the portfolio page, the icon will link to the portfolio item page itself.

Hope this helps.

This worked, thanks.

1 Like

You’re most welcome!

I thought the issue was fixed, but its not, the solution worked for the blog pagination, but the portfolio is still giving me dup titles and descriptions.

Hi there,

I checked and I don’t see any title and description duplicates in portfolio items or portfolio index page. Would you mind providing a screenshot?

Or perhaps it’s due to cache since your pages are served through CloudFlare and optimized by RocketLoader? Could you try disabling them for a moment and check it again?


See here. Also there is something strange with



Since you are using SEO Yoast please make sure to add meta description to each of your portfolio item and pages.


Hi Have in both the template and single portfolio page, I dont think adding it to the individual items will help with the error Im having, the error im getting is with the pagination of the main portfolio index.

Hey @logoglo,

The %%page%% Yoast SEO meta template does not work with the Portfolio Index. Most of the tags works. By the way, the meta description setup should be done in the portfolio page. That is the page you’ve set the Layout - Portfolio template.

The Portfolio page uses the WP Query so I’m not sure if it’s an issue with Yoast or X. I’ll post this in our issue tracker. But please also forward this to Yoast SEO support. Maybe the %%page%% meta template won’t really work inside a page post type even if the page template displays a loop.

For now, regretfully, there is no solution to this but to disallow Google from indexing the Portfolio Index page or use The Grid or Essential Grid to display your portfolio items.

Thank you for understanding.

I too have this same issue Duplicate title



I checked the Open Graph was disabled in xtheme so Yoast was controlling it,
BUT I cannot see where to change the title of the blog ?

Where can I fix this ?


Hello @markw1,

Thanks for updating this thread. Normally, if you are using the default header, the landmark header which contains the blog page title will display. You can change the blog title by editing your Blog page in Pages > {name of your page assigned as Posts Page} or in X/Pro > Theme Options > {your stack} > Blog Options > Blog Title.

Please be aware that when you create a custom header if you are using Pro theme, the default header will get replaced by the custom header and the landmark title which has the blog title will no longer displays.

Hope this helps.