Disable Real-Time Automatic Change Updates in Cornerstone


I find the “update-every-single-letter-I-type” feature of the Cornerstone Editor to be really unnecessary and frustrating. Is there any way to toggle this to an “update-when-I-click-this-button” that would be on the left side there with the CSS/JS/Save/Gear icon, etc?

This would be awesome.

Hi @nykzukowski,

Thanks for reaching out.

May I know what do you mean by real-time automatic change update? Or are you referring to the preview? It’s up to you when you should save it and that’s when you click the save button.


Hey Rad, for example, the live preview in Cornerstone is trying to keep up with every single character I type and update the preview, but I have a lot of elements on my site and it bogs when I am trying to type something out.

So…there’s a Save button you save with; there could be a Preview button, not unlike WordPress itself with Publish/Draft, that when you press it, the live preview will update.

Thanks. Hopefully I explained it okay.

Hello @nykzukowski,

Thank you for the clarifications. Regretfully you cannot turn off the live text editor in the live view panel. I would highly recommend that you use the element text editor and not the live view editor in the preview panel.

Hope this helps.

Hey RueNel,

Thank you very much for the prompt response and the info. Oddly enough, the Element text editor is the only way I can edit text on the page. Clicking on the elements in the live view brings up the customization panel, which includes the text editor, and I make changes there.

I don’t get the formatting options pop up when I select an element. This could, perhaps, be a conflict with another plugin, but I really doubt that.

Thanks again!

Hi @nykzukowski,

Perhaps you had the advanced mode disabled on your settings that is why you are not seeing the options. Please click on the cog icon on the settings area then enable the Advanced Mode option.

In case the advanced mode option is already enabled but you are still having an issue, kindly try testing for a plugin conflict. You can do this by deactivating all third party plugins, and seeing if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.

If the issue persists, please provide us with the admin access to your site in a Secure Note:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.