Custom menu for portfolio items

Hello. When the portfolio template is used, all individual portfolio items will display the Home Page menu. Because my Home page utilizes the one-page navigation feature, the menu on the Home page navigates to specific locations on the home page, as it should. For all other pages on the site, I created a custom menu for navigation and assigned it to each page. This works great, except for “portfolio items” which displays whatever menu is assigned to the home page. Is there any way to over-ride this and get the portfolio items to display my custom menu?

I’m thinking not…

Let me know. Thank you!


Hi Michael,

Thank you for writing in, you can actually set a specific Header for all of your Portfolio posts or to specific one just like on how you set a header for your pages.


Please clarify if this is not the case on your end.


Thank you; however, this screen capture looks unfamiliar to me. Can you please provide me the path so I can find it and test it out?

Thank you.


In researching this a bit, it appears you are referring to the X-Pro version, which I do not have. Do I understand correctly that I can swap my X license for a Pro version at no cost?

Hello There,

Thanks for updating in. I apologize for the confusion. Lets go back to your issue. In your homepage, you have applied one page navigation for the menu. Please be aware that the correct way of setting the one page navigation is to have two separate menus. One menu will be used as your primary menu and the second menu will be used exclusively for the one page navigation option for your homepage.

In order for your portfolio items to have the default and working menu, you must assign the menu as your primary menu. And in your homepage, you will need to edit the homepage and find the “Page Settings”. This section is the place where you can find the one page navigation option for you to assign the second menu, the one which will be used exclusively for one page navigation. If you are using Cornerstone, please edit your homepage in Cornerstone, go to the settings tab, Settings > X Settings and find the one page navigation option.

If you want to review how you can set up the one page navigation, you can check it here:

Hope this helps.

OMG, I’m an idiot! Thanks for redirecting me :slightly_smiling_face:


We are just glad we were able to help you out.