Creating a Portfolio issue

Hi I have tried to create a Portfolio using your knowledgeable article. However, clearly I have done something wrong.

The portfolio page is

Are you able to advise what I have done wrong?

Many thanks

Hello There,

Thanks for writing in! You have set up the portfolio page correctly. The issue is that no image is displaying because each of your portfolio items doesn’t have any featured image. Please edit each of your portfolio items and insert a featured image so that it will be display in the portfolio page. To know more about how you can set up he portfolio and other settings, please check this out:,

Hope this helps.

Hi and very many thanks for your help. I am still having issues in that nothing is appearing on the Portfolio page. I believe that I have followed the kb article but am puzzled as to what I have done wrong

Many thanks for your continues help

Hey There,

Since you have installed a caching plugin WP Super Cache, please clear your plugin cache before testing your site. This can cause the changes to not take place on the front end. It will eventually show up when the cache regenerates, but it’s not ideal if you’re looking to see your changes immediately. Caching plugins are best to turn on only when you’ve finished building the site.

If still nothing is working, please provide us the url of your site with login credentials so we can take a closer look. This is to ensure that we can provide you with a tailored answer to your situation.

To do this, you can create a secure note with the following info:
– Link to your site
– WordPress Admin username / password

Thank you.

Thanks Have tried Cache and still no luck. Have created you a username and password and sent via secure note.

I have created a new portfolio page in case that was the issue it is but the same is happening, no images are being displayed.

Again thanks for your continued help


Hi Alex,

I’ve tried to log in with these username/password but I couldn’t, could you please double check this issue for us?


Sorry I mistyped the Secure note. Have now corrected and test.

Hello There,

I have logged in and I found out that you are experiencing the issue because you have added this custom css (

.entry-featured {
    display: none;

So I went ahead and resolved your issue. I have updated the code and use this instead:

/* Portfolio adjustments */
.entry-featured {
    display: none;

.page-template-template-layout-portfolio .entry-featured {
    display: block;

Please check your site now.

Thanks very much - works a treat.

Have a great weekend

You’re welcome!
Thanks for letting us know that it has worked for you.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.