Cornerstone won't open any page CONTINUED

Hi @Leanna,

The best approach for now to narrow down the troubleshooting for possible causes is cloning your site to a different host for testing, and for comparison.

I’m not sure why your host didn’t see the 0 max execution time, I checked again and yes, the local value is now set to 300 instead of 0.

I’ll continue checking for now.


hey Rad, truly appreciate that! Well the instructions to move it entirely to a different host sounds both time consuming and difficult for a non-programmer like me. I’ve spent way more time fighting this than I can afford out of my extremely busy schedule as a nonprofit director (i end up chasing these issues because none of my staff members even understand basic html) I’m at the point I’m glad to pay something to get this fixed by someone who knows what theyr doing.

Hi Leanna,

Unfortunately, we do not have any paid support service for this matter. I suggest that you check for freelance developers in the social media.

We are really sorry for the inconvenience, but indeed your case needs more detailed attention and the steps we asked you to do is the way to find out if it is related to the server or the database problem.

Thank you for your understanding.

Rad - earlier you identified error "Uncaught TypeError: Cannot assign to read-only property ‘contains’ of object ‘[object Array]’ on page and said you could diagnose it if I set up a Staging site. I’ve set up the site which is - would you mind checking on that - prhaps there is an error on each page that won’t open… but that doesn’t explain why a BRAND NEW page won’t open either! So maybe that is a rabbit trail…
I’m afraid to hire those freelancers from India as last time I did I got full of malware, and the US freelancers cost too much…

Hi there,

The purpose of staging is to test it in different environment. And what you did is just staging through plugin which basically, just the same installation, same instance, and same issues. Have you tried staging to a different host (must not have internal caching)

Hence, it’s only normal if we’ll see the same issue. And the purpose of that staging is also to narrow down the search but we can’t assure that we could diagnose the real cause. The direction we’re looking at now is host environment since the theme and plugin works on other hosting.


ok I signed up on Hostgator and moved over to them and guess what - same problem. Therefore I guess we can rule out server issues. Since this isn’t a problem on X Theme where I never upgraded to Pro, at least plz help get Cornerstone functional back on X Theme and get rid of Pro entirely. NOTE I already tried switching back to X Theme but whatever corruption Pro has introduced to these two sites is causing Cornerstone to continue giving the error even after downgrading.
Hostgator tech says please tell them what are the PHP Variables of the X Pro theme so they can set them accordingly in the server (at least that’s how I understood it). Not sure if that will solve anything?
Are there any clues here?

Hey Leanna,

Since you already moved to HostGator, could you please provide us access to the site and to your FTP so that we can test this new server and maybe figure out what is the caused of this problem? This issue is something unique to your installation since there are X/Pro users using Hostgator with no issues at all.

To do this, you can make a post with the following info:
– Link to your site
– WordPress Admin username / password

  • HOSTGATOR FTP Hostname
  • HOSTGATOR FTP Username
  • HOSTGATOR FTP Password

Thank you.

Thank you! See secure note…

Hello There,

I have logged in and edited your wp-config.php file.
I added this:


This line is suppose to increase the PHP time limit because currently it is set to zero. This line does not change anything. It seems as if the server is blocking and imposing to have 0 PHP time limit. Could you contact your hosting and ask them to make sure that your PHP time limit is at least 600. We can easily check all these variables in WooCommerce > Status. Zero PHP time limit will prevent Cornerstone or Pro editor to load.

Please let us know how it goes.

1 Like

Good try… but I attempted to open a page in Cstone in two browsers - no change, same problem. Ok I finally got the FTP info but it’s not working yet, they say it’s because the site is still propagating, but it shows fully propagated…

Ok I got the FTP info: see note.

Hi @Leanna,

As @RueNel said, he already changed the limit to 600 and it remains 0. And with 0, the builder will not work. Have you contacted your hosting provider about that? If not, then yes, there will be no change and will be the same.

I’m also baffled but this page (page ID 260) it doesn’t exist in your pages or posts but viewable on that URL. Maybe it’s related to propagation and what I’m seeing is still the old site, in that case, let’s wait for 24 to 48 hours for propagation and let us know. That could be the reason why it still displays 0 as we still see the old one (from old host), let’s check it again later.


Note that the site we’re working on (and which we moved from Inmotion to Hostgator for the purpose of diagnostics) is, not I logged into and “about us” is there in Pages. Try searching “about” you’ll see it.

You noted that @RueNel changed the limit to 600 “and it remains 0” - I called Hostgator and they accessed wp-config and noted that “set_time_limit” was set to 250 so they upped it to 600. Meanwhile I accessed the previous wp-config on Inmotion server and noted the time limit there was already set to 900. So please guide me to understand where is it that “0” is showing up?

Hi Leanna,

Head over to the link in the secure note and then click on the display PHP information.

Then find following value in the browser (max_execution_time).

On top of the column, you will see Local and Master values as my colleges mentioned above.

Hope that’s clear now.

Wow, I didn’t know all that existed. Ok i see you installed a plugin to bring server info into the dashboard. Cool. So I contacted Hostgator and they changed the 0 value at max_execution_time to 30. That value was set up in a hidden file called .user.ini - also the master value was 300 in 4 different files including public.html and home directory etc. - he changed it to 30. Now shows 30 for both Local and Master, however inside WP at it still shows zero. he said the real value is what we’re seeing at phpinfo.

Cleared cache, and tried to open a page with Cornerstone - still no change. :cry: :cry: :cry:

What if it is in fact the remnants of some plugin which is still messing things up even when we disable all the plugins?
I think about the time I started having trouble with Cstone in these two websites was when I also installed WP Smush. The plugin is deactivated, but could that have messed something up resulting in Cstone not working properly/not able to open certain pages? (but that doesn’t explain why it won’t open brand new pages either, unless Smush messed with actual theme files…)

Hi @Leanna,

The real value is the active one which is used. The master value is just the default value which can be overridden by local settings like user.ini, which can also override by PHP code set_time_limit(). And unfortunately, I’m not sure which one is honored.

The phpinfo.php picks up the setting correctly, but Wordpress and other scripts could have their own set values too which locally changed. The phpinfo.php is just a single file compared to Wordpress.

I’ll continue checking, I deactivated both theme and plugin and when I checked the admin in the console, it still displays Slow network detected in my console. Is it okay if we disable your SSL/HTTPS while we’re investigating? It just has URL redirect and MIX content fixer which may be altering the data payload.


1 Like

Hi Rad, YES please feel free to disable anything you have to in order to figure out the problem. We’re experimenting on this site because it isn’t nearly as important as If this site ( goes down for awhile it’s no big deal so experiment away!


Hi @Leanna,

Looks like the timeout is solved, then new issue appears which originating from your footer widgets. I deactivated your footer widget in Theme Options and the builder now starts loading.

It’s because of the codes you added in text widgets.


1 Like

YOU SOLVED IT!!! AMAZING!!! BRAVO!!! Where do I go to give X Theme tech support 5* and an over-the-top review?
In all previous experiments, we had deactivated plugins and removed the code from Customizer but NEVER thought of widgets! I just deactivated footer widgets in on the other server, and sure enough on that one too… walla, Cornerstone works! I narrowed down the footer error to this piece of java (my blog signup form):

<script type="text/javascript" src="" margin="0px" padding="0px"></script>

Any idea how I can use this web form in the footer widget without messing up cornerstone?

Hi @Leanna,

The problem is not that exact code, but the code it generates on-fly which the builder is unable to capture and caused issues. I recommend deactivating your widget while working in the builder. In widgets section, you can drag your widgets to inactive sidebar.


1 Like