Cornerstone Visual Builder Broken


I just updated X-Theme to 6.2.2 with cornerstone 3.2.2 - I am now unable to preview or even pick certain elements out on my visual editor page. They just appear white or in some cases, missing altogether (such as a raw code-block being missing/unclickable). The skeleton editor view works fine and the page renders fine when viewing the site.

What to do about this?

I’m serving from localhost, so if you really need to see it, you’ll have to let me set up a tunnel. Give me a heads up first.

Hello There,

Please follow up the steps below:

  1. Ensure everything is up to date according to our version compatibility list here. Please follow the best practices when updating your theme and plugins. Click here for more information.
  2. Go to X > Settings and click on the Clear Style Cache button.
  3. Test for a plugin conflict. You can do this by deactivating all third-party plugins, and see if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.
  4. Remove custom CSS and Javascript from the options or Child Theme and test the case.
  5. Reset your htaccess file by renaming it to .htaccess-bak. Then in WP Admin Menu, go to Settings > Permalinks and just click the Save Changes button.
  6. Increase the PHP Memory Limit of your server. Click here for more detailed information and how to increase the PHP memory limit.

Thank you.

Thanks @thai.

This is a fresh install. I’d follow your compatibility guide but it’s out of date. I just finished updating to 6.2.3/3.2.3 and the problem is still persisting.

I’ve cleared the style cache (again), increased the PHP limit, there is no .htaccess in my public_html folder - not that it matters, the visual editor (drag & drop editor?) was working fine prior to the last update.

The only plugin installed is cornerstone aside from the 2 default wordpress plugins (Akismet and Dolly).

Funny enough, updating to 6.2.3 broke my child theme, so I had to delete it. Before I reinstalled it, I checked the drag n’ drop builder, it’s still broken.

Without any useful error messages in the console, I’m at a loss. The only thing I can think of doing is wiping the slate clean and trying again. Short of doing that, please see my private note. I have launched a tunnel so that you may check it out yourself.

Hi Tratz,

Thank you for the tunnel, but it does not work, the site is still trying to pull most (if not all) of the resources from your localhost (local.mavens.test see screenshot below)

Please confirm that your PHP and MySQL version is higher than 5.6. And also try to use a different browser (except IE)

If your main issue is the same on that other thread, then that is normal. Cornerstone does not support previewing your 3rd party scripts. So you need to view that element on a Skeleton Mode to edit it.


1 Like

Thanks for the response. I can accept that raw code blocks that just run JS or CSS become intangible outside of skeleton. The thing that throws me for a loop is the fact that the video player preview is now gone, too, whereas it worked before. The lack of consistency between these two things makes me feel concerned about other elements not previewing in Cornerstone.

Again, this only happens in the page builder. The website looks fine.

It worked great on my end, but I have a modified hosts file. OOPS. I’ll try to get you a better tunnel tomorrow.

Let us know once you have those information.


Hello @mldarshana & @friech or whomever this still concerns,

Thanks for sticking with me so far.

I have setup a public test site. Please see the following secure note to gain access to it.

Hi There,

I was able to edit your home page with Cornerstone without any issues. Which pages are you still facing the issue?

Could you please clear all the browser caches, cookie or try in the incognito mode?

Let us know how it goes!

Please read the whole thread, especially

Hey @Tratz,

I have replicated the issue with the video in my test site so this looks like a bug. I’ll post this in our issue tracker so our development team could be made aware once they go through the list of reports.

For now, the only easy way to access the hidden elements is to use the Skeleton Mode.

We’re sorry for the inconvenience.

1 Like

I just wanted to chime in here to let you know we’ve corrected the issue with the video preview. This will be part of the next release.

1 Like

Thanks @christian_y / @alexander Now that I know this isn’t expected for visible elements, I’ll report any others that I find.

To you and all the others, I appreciate the support.

You’re welcome! :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.