Cornerstone unable to load page


Currently, cornerstone is unable to load any pages for editing on my wp site. Instead, there is just perpetual loading. The error does not seem to be associated with any updates; I have not done any work on the site for weeks before the problem emerged. Having updated both X! and other plugins, nothing has changed. The problem persisted before and after.

Additionally, the need to edit the page in the first place was done due to images disappearing from the website, despite the images existing in the wp-contents folder and thus being fully accessible to the site - is this an issue pertaining to Pro / X! ? It seems odd to simply have to go in and re-add pictures that available in the contents folder.

Hopefully, someone with more expertise can assist with this issue.

Best regards,

Hello Jakob,

You might need to have the PHP memory limit of your site increased.

To do this, please edit your wp-config.php file and insert these lines:

    define( 'WP_MEMORY_LIMIT', '256M' );
    define( 'WP_MAX_MEMORY_LIMIT', '512M' );

You can add it before the line
/*That's all, stop editing! Happy Blogging. */

Here is a details article about the PHP Memory Limit that is in our Knowledge Base:

In case the issue persists, please try to get in touch with your hosting provider and confirm to them that your PHP memory limit is increased.

I also tried to checked your account to see the website you might having issue with but I could only see a Cornerstone license in your account and there is no domain associated with the license.

If you are still having an issue, please provide us with the admin details of your site in a Secure Note so that we can check this further.

Hello Jade,

Thank you for your answer. I have done as you suggested and increased the memory limit to 512M but it has not had any effect on my problem. I have checked that the memory has actually been increased as well.

I will provide information as requested in a secure note.

Thank you

Hi Jakob,

I have checked your site and you have updated Cornerstone to the latest version but left X not updated which is causing an incompatibility issue.

So kindly make sure to update X as well then clear your site’s cache.

Hope this helps.

Hi Jade,

I tried updating X from 7.0.3 to 7.0.4 as you suggested but it has not made any difference to my problem. Cornerstone remains unable to load any pages for editing.

I have cleared both the cashe of the WP site and the browser.

Hopefully you have other suggestions, thanks for the assistance thus far.

Hello Jakob,

Thanks for updating the thread.

I checked the website and opened few pages in Cornerstone and inspecting the page in dev tools I see following error message:

POST 404 (Not Found)

Please take a look at the solution shared in following thread and if in case issue is still there please share FTP or Cpanel access in secure note to take a closer look.


Hello Prasant,

Thank you for the suggestion, though approaching the deep end for a front-end user. I have attempted the suggested solution, to my knowledge there is no use of a CDN,

Unfortunately, Cornerstone remains unable to load any pages.

Hello Jakob,

I have logged in and I can confirm that even the X > Theme Options were not loading. Is your ModSecurity enabled? Please contact your hosting provider and ask them to whitelist this url in the secure note.

Please let us know how it goes.

I have exactly the same problem and the same error with no CDN and ModSecurity disabled.
Thank you for your help.

Hi @ejakobowicz,

Thank you for writing in, please make sure that you’re on the latest version, WordPress 5.2.3, Pro 3.0.4, or X 7.0.4 and Cornerstone 4.0.4.

Updating WordPress
Updating Your Themes and Plugins

Remember to clear all your caching features (plugin, server-side, CDN, and browser’s cache) after updating so that the code from the latest release is always in use. This will help you to avoid any potential errors.

If the issue persists, please create a new thread and provide us your site URL and login credentials there.

How To Get Support

Let us know how it goes,

It seems the problem is related to a plugin conflict between Cornerstone and Polylang.

Hey Emmanuel,

It’s good to know that you have figured out the Polylang plugin was the casue of the issue.
If you need anything else we can help you with, don’t hesitate to open another thread.

Best Regards.

I can confirm, as Emmanuel pointed out, that disabling Polylang resolves my issue and therefore indeed is the “cause” of this issue.

Hopefully this will be fixed soon, so that Cornerstone can be used with multilanguage again since multilanguage is generally more important.

Thank you for all of your assistance, both staff and Emmanuel!

Hey Jakob,

I’ll post this in our issue tracker so it will be queued for investigation by our development team.

For now, please revert to a previous backup or working state of your site.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.