Cornerstone trying to display staging image URLs


The link above shows a proper image path on the front end, but won’t show the correct image path on the backend, in Cornerstone. It shows an image path from the staging URL.

Any ideas?


Hi Charles,

It seems that the page was edited outside Cornerstone which is causing the issue.

Please note that editing the page outside Cornerstone will most likely present issues when you try to edit the page back in Cornerstone.

If you have a backup of the page, kindly try restoring the page from a backup then see if the issue gets fixed.

Thank you.


Nothing was touched in the text. Just viewed.


Hello @ca2450,

Thanks for updating the thread.

I clicked on the Edit with Cornerstone and the page is working fine. Upon checking the page I can see that the image link is broken in backend and is pointing to (URL in secure note).

I suggest you to use the Better Search Replace plugin to update all the links on your site to the new domain. Here’s a tutorial that you can refer.



Please read my original comment. The links are correct on front end, incorrect in cornerstone.


Hi There @ca2450

Sorry for the inconvenience caused. Your issue could occur due to various reasons.

  1. Improper migrations: You need to follow our migration guide here ( and make sure that you have migrated your site correctly to avoid such issues.

  2. Caching issues: Often times caching also could such issues. I would suggest you to purge your server cache and then disable caching plugins while you’re testing your issue (refer:

  3. CDN Cache: I see that you’re using CloudFlare on your site. Login into your CloudFlare account and clear your CloudFlare cache as well.

However when investigating this issue further, it seems that you’re using SiteGround for your hosting. There is also a known issue for SiteGround hosting. Please head over to the following link ( and check for the heading “Seeing the error in a SiteGround staging environment” and follow the instructions correctly.

Let us know how it goes.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.