Cornerstone stops working

I am using cornerstone 4.1.1 and X 7.1.1. But it does not work (spinning forever). Previous version of cornerstone works fine. Can you help either suggest a working solution or provide a link to previous version?

I used chrome inspect and found the following errors:

JQMIGRATE: Migrate is installed, version 1.4.1
/cornerstone-endpoint:1 Failed to load resource: the server responded with a status of 500 (Internal Server Error)
cs.2803d6d.js:4722 Rejecting AJAX promise Object
d @ cs.2803d6d.js:4722
cs.2803d6d.js:4711 Rejecting Controller promise Object
r @ cs.2803d6d.js:4711
cs.2803d6d.js:2311 Object
(anonymous) @ cs.2803d6d.js:2311
cs-vendor.2803d6d.js:1897 Uncaught TypeError: Cannot read property ‘elements’ of undefined
at e.default (cs.2803d6d.js:4879)
at a.callback (cs.2803d6d.js:5058)
at a.exports (cs-vendor.2803d6d.js:18)
at a._reify (cs-vendor.2803d6d.js:21)
at a.reify (cs-vendor.2803d6d.js:20)
at a.exports (cs-vendor.2803d6d.js:17)
at a._reify (cs-vendor.2803d6d.js:21)
at a.reify (cs-vendor.2803d6d.js:20)
at a.exports (cs-vendor.2803d6d.js:17)
at requireModule (cs-vendor.2803d6d.js:5)

Hello @cuixu,

Thanks for writing in!

A loading Cornerstone logo may indicate a fatal error in the background which could be because of the PHP Memory Limit exhaustion. ​We recommend that you increase your memory allocated to PHP. To increase it, please edit your wp-config.php file and insert these lines:

define( 'WP_MEMORY_LIMIT', '256M' );
define( 'WP_MAX_MEMORY_LIMIT', '512M' );

You can add it before the line
/*That's all, stop editing! Happy Blogging. */

If this does not help, please go to X > Status, click Copy Results and include these results in your next reply

We would love to know if this has work for you. Thank you.

Thank you for your quick reply. My wp-config already have those two lines, and I also tried to increase the limit but it does not work. Below are X status:


Site URL -
Home URL -

WordPress Environment

Version - 5.1.1
Debug is on - No
Language - en_US
Is Multisite - No
Memory Limit - 512M

Web Server Configuration

Software - Apache/2.2.15
PHP Version - 5.3.3
MySQL Version - 5.1.73

PHP Configuration

Post Max Size - 2000M
Time Limit - 30s
Max Upload Size - 2000M

Active Theme

Name - X – Child Theme
Version - 7.1.1
Folder - //var/www/html/
Parent Theme Name - X
Parent Theme Version - 7.1.1
Parent Theme Folder - /var/www/html/
Cornerstone Status - Enabled
Cornerstone Version - 4.1.1

Active Plugins

  • Add Widget After Content 2.4.1
  • Akismet Anti-Spam 4.1.3
  • Cornerstone 4.1.1
  • Duplicate Page 4.0
  • Header and Footer Scripts 2.1.1
  • One-Click Child Theme 1.6
  • Slider Revolution 6.1.5
  • SSH SFTP Updater Support 0.8.2
  • Wordfence Security 7.4.1
  • WP Mail SMTP 1.7.1
  • WP Rollback 1.7.0
  • WPForms Lite
  • X – Google Analytics 1.0.3


Click this button to check what CDN this site is using. - Check CDN

Hey @cuixu,

Your setup looks fine except the Time Limit which you could try setting to 120s. Your web host could assist with this. Tell the web host to increase the max_execution_time.

Aside from your setup, there could be other third-party factors that could be causing the issue. If you have not done so already, please try these troubleshooting steps below. Increasing memory and making sure everything is up to date are only part of the troubleshooting. There’s more to check.

  1. Try clearing your browser’s cache and also test loading Cornerstone in the browser’s incognito mode and other browsers like Firefox.

  2. Test for a plugin conflict. You can do this by deactivating all third party plugins, and seeing if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.

  3. Switch to the parent theme. This will quickly tell you if the child theme is causing the issue. You should inspect the custom codes you’ve added in your child theme if this is the case.

If this still doesn’t help, please give us the following information in a Secure Note so we could investigate deeper.

  • WordPress Login URL
  • Admin level username and password
  • FTP access


Unfortuntely none works. I am sharing the secure info.

Hello @cuixu,

You are having this issue because you are using an out dated WordPress core (5.1.1) and PHP 5.3.3. Please update your PHP version to at least 5.6 or 7.2 and then WordPress to at least 5.2.3 so that X and Cornerstone will work.

For best results, please make sure that you server meets the requirements to run the latest WordPress.
You can check it here:

Please let us know how it goes.

Unfortunately, due to complicated reasons, we can’t update the php version (I know it’s better to). Do you mind sending me the link to download previous working versions of cornerstone and X?

On a related topic, if our server has two versions of php, is it possible to let the wordpress use one version, but other programs use another version?

Hey @cuixu,

I’m sorry I forgot to add that you can download the previous stable version in your Dashboard. The link is located under the latest version download button.

To your question:


Hope that helps.

Using cornerstone previous version (3.5.5) did work! Thank you!

However, it introduced a new problem: all the icons on our site is either gone or become a black circle. Is it possible to send me a download link of cornerstone version right before 4.1?

I think it’s good now

Hi @cuixu,

Glad that sorted things out on your end.

To others that might having this same issue, please make sure that you’re always in the latest version of X and Cornerstone (and Pro if you’re using Pro), and latest Wordpress version as well. You can always check what are the latest versions on our changelog page.

Updating WordPress
Updating Your Themes and Plugins

Remember to clear all your caching features (plugin, server-side, CDN, and browser’s cache) after updating so that the code from the latest release is always in use. This will help you to avoid any potential errors.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.