Cornerstone Problem After Update - Latest Blog Post Not Showing

I updated Cornerstone and can no longer edit within Cornerstone. My latest blog post is also not showing up on the main homepage. Help?

Hi Justin,

Thank you for writing in, please make sure that you updated both X and Cornerstone to the latest version (X 7.1.1 and Cornerstone 4.1.1 as of this writing).

Updating Your Themes and Plugins

And another important thing, please make sure that your Wordpress is in the latest version (5.3) as well, Cornerstone will not work if your Wordpress is in 4.9 or lower.

Remember to clear all your caching features (plugin, server-side, CDN, and browser’s cache) after updating so that the code from the latest release is always in use. This will help you to avoid any potential errors.

Hope it helps,

OK, so I updated Wordpress to the latest version…5.3. I can now edit within Cornerstone (and see the latest post). I’ve cleared my cache with WP Fastest Cache, however I still can’t see the page live. I’ve cleared browser cache and still don’t see it. Any ideas?

Hi Justin,

Please clarify what do you mean “can’t see the page live”, and please provide us the direct page URL and login credentials in a secure note so we can take a closer look.


I still don’t see the latest blog post on my homepage.

My latest blog post is regarding Best Backpacks for Day Hikes.

Hi Justin,

This seems to be a caching related issue because when I check your site, I see the X and Cornerstone and Wordpress are not up to date.

And yes, the “Best Backpacks for Day Hikes” post is not showing up.

But if I access your site like this: I see everything is up to date and the “Best Backpacks for Day Hikes” post shows up.

Please make sure all your caching features are Cleared, yes even those deactivated ones, enable those and make sure to clear its caches. And please contact your hosting they might have a server-side caching feature, make sure those are clear too.

Let us know how it goes,

Thanks so much. It ended up being cache at the CDN level that was causing the issue!

Cool, we are delighted to assist you with this.

Have a nice day,

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.