Cornerstone not working with woocommerce installed

Hi, I get:
“The preview was unresponsive after loading. This is most often related to a plugin conflict or aggressive page cacheing.” when trying to edit a page with cornerstone. I turned off all plugins and cashe. The plugin woocommerce was the one causing trouble, but we need that one. Memory limit ok, everything updated.

Hi There,

Thanks for writing in! What’s the WooCommerce plugin version that you’re using? We recommend the version listed here on our compatibility guide (

You can download the exact version by going to this link ( and check the section called previous versions.

Hope that helps.

It has got 3.25, not 3.11. Do I need to downgrade WordPress and other plugins as well? When will you support the latest WooCommerce?

I never ran across the issue with not supporting new plugins before. Does this means it’s recommended not to update?

Enybody else having this issue? Updated X with updated cornerstone not working with uppdated Woo right now. Anybody solved it?

Hello @paal,

Thanks for updating the thread. :smiley:

We always suggest our customer to keep on runnning compatible version of the plugins and for that we maintain a version compatibility guide. It’s compatilitely up to you wether you want to run a compatible version of WooCommerce or latest vanilla version. In your case if you choose to run compatible version that can you will have to downgrade WooCommerce. You can refer following guide to downgrade WooCommerce:

It’s not that we suggest our customers to refrain from updating plugins. However, runninig plugin a compatible version of plugins make sure that it won’t cause any problems with the website workflow. Most of the times we have noticed that customers installing latest vanilla version of plugin breaks website workflow.

As of now I am not in a position to give you ETA but rest assure our developers are working to release latest version of WooCommerce that’s compatible with our products.

Thanks for understanding.

We just downgraded it. It does not work with WooCommerce 3.11 either.

Also tried with other sites. Looks like X theme and WooCommerce is not working, regardless of version. We have tried the supported 3.11, the 3,23 and the 3.25.

It looks like the errors are in Chrome. Tried open in Safari, and it worked.

Hi there,

Please try to go to Woocommerce > Settings > General options then set Default customer location to No location by default then try to load the pages in Cornerstone again.

If this does not work, please provide your admin and FTP details in a Secure Note.

Thank you.

Hey I’m actually experiencing the same exact issue as well. Can I give you my FTP credentials to take a look on my end?

edit: I’ve also did some troubleshooting and determined that Cornerstone is only unable to edit when Slider Revolution and WooCommerce and installed concurrently. I was able to edit using cornerstone when on WooCommerce 3.2.5

Hi there,

Please review this article listing some troubleshooting tips:

Hope this helps.

Okay thank you for that. Just an FYI: I done some troubleshooting and determined that Cornerstone is only unable to edit when Slider Revolution and WooCommerce and installed concurrently. I’m going to do some more troubleshooting and hopefully I can resolve this issue!

Hello There,

To better help you resolve your issue, at this time we kindly ask that you open up the issue in a separate thread. The longer threads get in the forum, they become more difficult to support as they tend to drift off topic and they also make it troublesome for users trying to search for solutions. Keeping threads relevant to their original inquiry ensures that we can keep better track of what has been resolved and that users can more effectively find answers to similar issues they might be experiencing.

Meanwhile, you might just be experiencing PHP memory limit exhaustion. ​We recommend that you increase your memory allocated to PHP. To increase it, please edit your wp-config.php file and insert these lines:

define( 'WP_MEMORY_LIMIT', '256M' );
define( 'WP_MAX_MEMORY_LIMIT', '512M' );

You can add it before the line
/*That's all, stop editing! Happy Blogging. */

Thank you.

You guys are killer! Adding that to my wp-config.php file worked! Thanks a ton!

Glad that we could be of a help :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.