Cornerstone not working after updating

Hi, I updated X and WordPress, and now I cannot edit new pages or posts in Cornerstone. I can sometimes edit existing pages in Cornerstone, but never new pages. When I click edit in Cornerstone it just goes back to edit the post in Wordpress editor.

Hi There,

Thanks for writing in! First of all, try re-generating your permalink settings and see if that is related to your .htaccess file.

  • Check your permalink settings (General -> Permalinks) and set Postname save changes to re-create your .htaccess file.

Then the next possible issue would be that you’re running out of your memory. You can try increasing your PHP Memory limit. You can do this by editing your wp-config.php file which can be located under the root of your WordPress installation.

Add the following lines into that file.

define( 'WP_MEMORY_LIMIT', '512M' );
define( 'WP_MAX_MEMORY_LIMIT', '512M' );

You can add it before the line
/*That's all, stop editing! Happy Blogging. */

Check the following as well.

  • Make sure that you’re running at least PHP v5.6.x or later to avoid any WordPress related incompatibility issues. If you’re not sure what your server configurations and settings are, install a plugin like WP-Serverinfo ( and check your server info by head over to Dashboard -> WP Serverinfo area.
  • Check your PHP Max Execution Time and set it for 300 for optimal usage.

Further, our troubleshooting guide here (

Let us know how it goes.

Hi I have tried all of the above, except for PHP max execution time as I’m not sure how to do it


Kindly refer to the link below

Can you provide us you FTP Login in Secure Note


That guide is missing a pretty crucial piece of info, isn’t it? Where in the .htaccess file should I put the code? It just says “insert it.” I inserted it at the end and it broke my site.

Hi There,

No, that is actually the whole guide, open/edit the .htaccess file, insert the line php_value max_execution_time 300 at the bottom and save the file.

Looks like your Cornerstone is working fine now, I was able to open your homepage in Cornerstone and created a new page in Cornerstone. Is the issue only happening to specific pages? Please clarify.


Hi, the issue is only happening with new pages, but it’s still happening for me. Additionally, the link you sent me of the x text page didn’t work (blank white page), although I can see the test page when I copy and paste the URL. And I can edit it in Cornerstone. But if I try to add a new page and edit it in cornerstone, it just goes back to the text editor. I’ve tried this in Safari and Chrome, same result.

Also, I’ve again tried to insert the PHP Max execution time code, but again it broke my site. This was the result:

500 - Internal Server Error
This is a temporary server error.
Please try to reload the webpage later.
If you are the webmaster of this site please log in to Cpanel and check the Error Logs. You will find the exact reason for this error there.

Common reasons for this error are:

Incorrect file/directory permissions: Above 755.
In order files to be processed by the webserver, their permissions have to be equal or below 755. You can update file permissions with a FTP client or through cPanel’s File Manager.

Incorrect Apache directives inside .htaccess file.
Make sure you have not specified unsupported directives inside the local .htaccess file. Such include PHP settings and Apache module settings.

Hi jpenns,

You are getting this error because SiteGround (where you are hosting your website) doesn’t allow adding PHP values in “.htaccess” file, instaed they have their own “PHP Variables Manager”.

After I’ve created a new page on your website then with Cornerstone activated I got this error in the browser console:

It’s related to “AdThrive” plugin, could you please deactivate this plugin, then remove any AdThrive related code on your website and recheck this issue?


Hello, it’s not easy to remove their stuff from the website, as they installed it, not me, so I can’t just quickly do it myself. I have spoken to my AdThrive team about this, here is their reply.

The error that is being logged to the console does not affect Corenerstone’s functionality. These errors do not indicate any issues with the code or site functionality, they are just notices for the ad code which are logged as errors. In that screenshot I also noticed that admin-ajax.php was registering a 400 error. Admin-ajax provides a lot of functionality to the site and that file creating a 400 error is likely why Cornerstone is not functioning properly.

Hi there,

Judging the message your team given the error 400 is something related to your hosting service provider. I suggest that you contact them and ask them to exclude the Cornerstone endpoints and the admin-ajax from their mod_security settings of PHP.

They will know how to do it form their side.

Thank you.

Here is Siteground’s reply


I have carefully reviewed the logs and mod_security rules are not triggered by your website. It seems that the mod_security is not related in your case.

If you need any further assistance don’t hesitate to open a new ticket. You can open a new ticket from the User Area --> Support --> Request Assistance From Our Team.

Best Regards,

Vasil Miloykov
Senior Technical Support

Please. Can we escalate this or something? I updated X and it stopped working, and it hasn’t been working for over a week now. I’ve gone back and forth between three different support teams but the important part is that this is an issue with an X plugin, and it happens even when all other plugins are disabled and when all my caching is disabled.

Hi there,

The Ajax error is due to WPComplete plugin and it alters the ajax requests. But the main reason it’s not working is due to javascript error related to flex slider. It’s live so I can’t just disable all your plugins, you could try testing for a plugin conflict. You can do this by deactivating all third party plugins, and seeing if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.

Or backup your site and let us continue the troubleshooting. This process could reset plugin’s data (depending on which plugins).

Let us know how it goes!

Well, as I just said, I have tried deactivating all other plugins and the problem continues. I don’t see any javascript errors, but I’m not entirely sure I’m looking in the right place.

I have a scheduled backup tonight at 02:50am (GMT-5) so you could do some troubleshooting after that.

Hi there,

Thank you for the information. I actually managed to add a test Page 4 and it worked with no problem. The Cornerstone is working ok. Now how I managed to do that:

  1. I disabled all plugins except the Cornerstone
  2. I went to X > Theme Options > JS and removed the AdThriive code.

Now if you check the Test page 4 it is working with no problem. I had to add the code back and enable the plugins. Please test it yourself.

Thank you.

Thank you, unfortunately this doesn’t work for me. I took the JS code out and I disabled all my plugins except for cornerstone, and I still had the same issue. I tried it in Chrome as well as Safari.

Also could you please explain more about the javascript errors @Rad talked about, related to “flex slider.” I’m not using a plugin called flex slider. But I have experienced so many issues on the site recently that I need to eliminate any kinds of errors that might be causing problems.

Hi there,

You need to be precise on the report back as I still can work with the Test Page 4 with no problem. Please give us the exact test case that you do and exact problem that you are facing. Give us the steps to reproduce the problem while the 3rd party plugins are all deactivated and the Script in question is not there in the website.

The FlexSlider Javascript error went away as soon as I deactivated all the 3rd party plugins. The FlexSlider is used in some of the Elements of the theme and it is embedded to the theme itself, and one of the 3rd party plugins causes the issue @rad mentioned.

Thank you for your understanding.

As I stated, the problem is that I cannot edit new pages/posts. Once a page/post is created, as you have been able to do, working with it is no problem, but I cannot create new pages and work with them in cornerstone. Here it is demonstrated:

Hello There,

Thanks for providing the video. You are doing it incorrectly. You have to do the following steps first.

  • Go to Pages > Add New
  • Insert a page title
  • Click the “Publish” button
  • Click the “Cornerstone”
  • And finally hit the “Edit in Cornerstone” button.

Hope this helps.