Cornerstone issueeee


We use X theme with below versions:

Theme Version: 5.2.5
Wordpress Version 4.9.2
Running on SSL
Cornerstone 2.1.7

After Wordpress update and using SSL in our website, cornerstone is not loading ( it shows the keep loading picture)

I tried to troubleshoot with Wordpress Debug on or browser console, rename .htaccess, clear cache,(we do not use custom CSS or java script or CDN),tested plugin conflict, increased memory limit ( it is hosted in our own server and network), went thru your forum but I could not figure it out!

The only errors shows in the console are:

Failed to load resource: the server responded with a status of 404 (Not Found) cs-vendor.js
Uncaught ReferenceError: define is not defined at cs.js

and this error in the page since I updated to wordpress debug to true:

Notice: Undefined index: WP_Widget_Recent_Comments in /home/xyrality/public_html/wp-content/themes/x/framework/functions/global/remove.php on line 36

Can you provide me the older versions of cornerstone, maybe I use them and it works, however this would be only the temp solution as it needs to be updated due to security sooner or later.

Please help!

Hi There,

Thanks for writing in! Could you please try deleting your Cornerstone plugin and then re-install it by head over to X -> Overview section.

Make sure to purge your server cache if you’re using any caching plugins and test your issue again.

Hope that helps.

Thanks for your answer, however I could not see CornerStone under overview section(not listed there!!see this screen shot ) so I have uninstalled it via plugin page and of course it is not listed there so I can not reinstall it from there! should I do it manually?!

It screwed up our website since cornerstone is not installed! and I can not find it anywhere to download it! please provide me the link ASAP!!!1

I manage to fix the website being screws up due to not having cornerstone by copying cornerstone folder from another domain that we have and use your theme under plugin folder and now our website is fixed, however the keep loading issue is still there!!

Please advise!

Thank you.

Hi There,

Thanks for the confirmation!
This issue may be due to several reason. Can you please confirm this steps.

  1. Ensure everything is up to date according to our version compatibility list at Please follow the best practices when updating your theme and plugins. See for more details.
  2. Clear all caches including browser cache then deactivate your caching plugins and other optimization plugins.
  3. If you’re using a CDN, please clear the CDN’s cache and disable optimization services.
  4. Test for a plugin conflict. You can do this by deactivating all third party plugins, and seeing if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.
  5. Remove custom CSS, Javascript and templates.
  6. Reset your htaccess file by renaming it to .htaccess-bak. Then in WP Admin Menu, go to Settings > Permalinks and just click the Save Changes button.
  7. Contact your host to increase your allocated memory or do it yourself by adding this code in your wp-config.php
    define( ‘WP_MEMORY_LIMIT’, ‘256M’ );
    define( ‘WP_MAX_MEMORY_LIMIT’, ‘512M’ );
    In case the issue persists, would you mind providing us with login credentials so we can take a closer look? Please provide following information:
    Set it as Secure Note
  • Link to your site
  • WordPress Admin username / password
  • FTP credentials
    All the best!



Thanks for the reply, however I have mentioned that I have made all the checks that you mentioned before, please check the secure note where I have provided the login details to WP admin panel.
Thank you.

Hi There,

While troubleshooting your issue, I removed Cornerstone from your plugins.

Usually by accessing Wp Admin > X > Cornerstone suppose to re-install itself automatically, that unfortunately did not happen.

I tried than various times to install Cornerstone via Wp Admin > Plugins without success.

The fact of Cornerstone not being installed causes your website to look broken, so to avoid that while we solve this, I have activated X > Under Construction Plugin with a maintenance message.

You can install Cornerstone via FTP to wp-content/plugins/ of your website and deactivate Under Construction Plugin and your site will look as before.

You can find Cornerstone on your X Theme Zip File on the path: x\framework\plugins

Sorry for the inconvenience.

In order to help you understand why these issues are happening to your site, please provide your FTP credentials.

Thank you

Thanks for trying, but you did what exactly I mentioned that I did myself( turn off plugins, replace cornerstone, etc…) why did you have to do it again even though I told you that I did this!!! and you had the security plugin disabled without my permission!!! and screwed up an official website for our company for 3 days /as it was weekend and I was not working!!! )how could you do such a thing!!!

Please have some one who knows what he is doing and some one professional reply to me and I will provide the FTP details to him!!!

Thank you!!!

Hi there,

We are sincerely sorry for the inconvenience which we caused while testing the website for you. Actually, we caught up surprised because of this as whenever we check the dashboard we do need to check different stuff even if the customers mentioned they did check, this is to make sure that we double check the case, we understand that it caused an issue for 3 days and we apologize for the inconvenience.

Now back to the problem you are experiencing, actually you did a great hint regarding the cs-vendor.js file not loading as it is the main file of the Cornerstone and needs to be loaded. I did get this error while trying to check the COntact page using Cornerstone:

There is a false alarm on one of the security software regarding a virus on that file which we already followed up with the developers of the software and we did not get any response. Here you can find detailed information regarding the case:

My guess is that the same thing is happening on your server and it blocks that file suspecting it having a virus. I suggest that you contact your server administrator and ask them to whitelist that file. I added the exact URL of that file to the Secure Note.

Our development team is in the process of changing the code in a way that prevents this false detection and it will be available in the February release, but I strongly suggest to contact your server administrator as it will be the quickest way.

Thank you for your understanding and patience.

1 Like

Dear Christopher,

Salam and thanks for your reply, I am the admin of the server and will check the file tomorrow and whitelist it in ClamXAV; you mentioned you have added the path in secure note ( although I will be able to find it be locate for the file name, but just in case) but I do not see any secure note, please update with that.



Any progress on this yet? I’ve got the same problem.


You can download the theme from your dashboard

Then unzip it in your computer and you will be able to get the file in pro\cornerstone\assets\dist-app\js
or if you are using xtheme unzip cornerstone in x/framework/plugins/ and you can get the file in cornerstone\assets\dist-app\js


As stated by my colleague, a fix will be included in the next release this Feb.


I am having the same issue right now… when I go edit in cornerstone it does not load the page, all the elements are on the left but I see nothing on the right.
This is so frustrating, I am not sure what to do!

Hi There @selbymedia

Please create your own thread and explain your issue briefly, then provide us a login credentials (wp and FTP) on a secure note so we can take a closer look. You can not provide us secure note here, because the original poster will see it.

How To Get Support


Adding the cs-venodr.js into maldet ignore path file, fixed the issue.

Thanks for the help.

For anyone who has this issue and do not want wait for the new patch:

I copied cs-vendor.js into wp-content/plugins/cornerstone/assets/dist-app/js/ ( since it was removed by maldet) and added the full path of cs-vendor.js into /usr/local/maldetect/ignore_paths

This fixed the issue, thank you

Hey @Xyrality,

Glad you’ve sorted it out and thanks for sharing your solution.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.