Cornerstone: Fatal error

When I click on the “install and activate Cornerstone” link, the following results:

“Fatal error: Call to undefined function wp_roles() in /public_html/wp-content/plugins/cornerstone/includes/classes/app/class-app-permissions.php on line 213”

The site is:

I have the latest version of “X” and other plugins.

Thanks for helping out.



Hi Karel,

If you are using the latest version of X, Cornerstone should be automatically installed and activated on the site.

Perhaps there are some files of X that was corrupted when you tried to update X to the latest version.

Here are some options you can do:

#1. Install Cornerstone Manually

To do that, please follow the instructions here:

#2. If the issue persists, try reinstalling X manually as well:

If you are still not able to have X and Cornerstone work on your site, please provide us with the admin and FTP access to your site in a Secure Note:

Hope this helps.

Thank you, Jade.
I had already attempted the suggested solutions, to no avail.
I have added a secure note to my first post.
Thank you for investigating.

Hello Karel,

There is a fatal error in your site when installing Cornerstone. To resolve this, please provide us you FTP. What you have given is just your WP credentials. The FTP details is needed so that we can check your theme and plugin files.

You can place the ftp details in the secure note when you reply.

Thank you in advance.


I have created an FTP account with access to the /public_html/ folder with the same credentials as before. (see secure note)

Thank you for helping out here.



Hi @ozzywood,

I was unable to login to your FTP account. Could you please double check?

Right now, please follow these steps so I can access to the WP Dashboard:

  • Connect to your server via FTP and navigate to your /wp-content/plugins/ directory.
  • Rename the previous cornerstone folder to cornerstone-previous.

Thank you.

Hi - My apologies.
I have updated the credentials in the Secure Note.
I hope it will work this time.

Hello Karel,

Is there an active IP restriction for the FTP of your site? I have just tried to login through FTP and the login details still do not work.

Kindly double check the FTP details or follow the previous suggestion made by @thai.

Thank you.

Hopefully it works now. I have updated the password in the Secure Note. Thank you.

Hello @ozzywood,

Thanks for updating in! I have logged in and investigated the issue. I found out that you are using WordPress 4.2.2 and the latest version is 5.2.2. This is why there is an error in your admin page. The wp_roles() function is a default WordPress function release in version 4.3 that we use for our theme.

To resolve your issue, please update your WordPress core to the latest version.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.