Cornerstone fails to load, stays on spinning icon

Hi, we’re having an issue where the Cornerstone editor will not open, it just stays on the loading page indefinitely.

I was wondering if you know of any incompatibility with the following plugins: Clean and Simple Contact Form, EWWW Image Optimizer, JCH Optimize, Magee Shortcodes, SEO Optimized Images, SEO Redirection, UpdraftPlus - Backup/Restore, Wordfence Security, Yoast SEO.

I’ve tried clearing browser cache, using a different browser (Chrome, Firefox, Edge), using a different account and adding the two lines of code to increase memory allocated to PHP.

Are there any other recommended actions?

Thank you.

Hello @Sintek_1337,

Thanks for writing in!

A loading icon screen would probably because you have exhausted your PHP memory limit. By default, WordPress will attempt to increase memory allocated to PHP to 40MB (code is at the beginning of /wp-includes/default-constants.php) for single site and 64MB for multisite, so the setting in wp-config.php should reflect something higher than 40MB or 64MB depending on your setup.

​We recommend that you increase your memory allocated to PHP. To increase it, please edit your wp-config.php file and insert these lines:

define( 'WP_MEMORY_LIMIT', '256M' );
define( 'WP_MAX_MEMORY_LIMIT', '512M' );

You can add it before the line
/*That's all, stop editing! Happy Blogging. */

We would loved to know if this has work for you. Thank you.

I’ve inserted those lines into the wp-config.php, but no change. Cornerstone still fails to load.

Hi There,

Please do the following

  • Ensure that you are fully up to date. WordPress, Theme, and Cornerstone (Version Compatibility)

  • Clear all the site caches (plugin, server-side, CDN, and browser’s cache) so that the code from the latest release is always in use. This will help you to avoid any potential errors. Please deactivate this caching features while we tackle this issue.

  • Test for a plugin conflict. You can do this by deactivating all third party plugins, and seeing if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.

  • Remove custom Javascript and custom templates (if any).

  • Reset your .htaccess file by renaming it to .htaccess-bak. Then in WP Admin Menu, go to Settings > Permalinks and just click the Save Changes button.

If the issue persists, please provide us the site URL and credentials in a Secure Note so we can take a closer look.

Let us know how it goes,

Issue ended up being a conflict with the plugin JCH Optimize (version 2.3.2). Thanks for your help.

Hello @Sintek_1337,

We are just glad that you have figured out a way to correct the said issue which happen to be just plugin conflict. Thanks for letting us know!

Best Regards.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.