Cornerstone Error After Switching Hosting From Themeco to WP Engine


I just switched our website from Themeco Hosting to WP Engine hosting but now am unable to save any changes in Cornerstone. I am receiving the error message “Uh oh! Content failed to save” whenever I go to save a page on Cornerstone. There were a few things that did not migrate on our site properly when we switched to WP Engine, so I would really like to be able to fix them!

We have version 6.1.3 of X and 3.1.3 of Cornerstone installed, so most recent versions of both. With our new hosting on WP Engine the PHP version is 7.0.

Please let me know what I can do to be able to save content again on Cornerstone. Thanks!

Hello There,

Please follow up the steps below:

  1. Ensure everything is up to date according to our version compatibility list here. Please follow the best practices when updating your theme and plugins. Click here for more information.

  2. Go to X > Settings and click on the Clear Style Cache button.

  3. If you’re using a CDN(ex: CloudFlare), please clear the CDN’s cache and disable optimization services. For the CloudFlare you also need to follow the steps below besides the developer mode:

  4. Test for a plugin conflict. You can do this by deactivating all third-party plugins, and see if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.

  5. Remove custom CSS and Javascript from the options or Child Theme and test the case.

  6. Reset your htaccess file by renaming it to .htaccess-bak. Then in WP Admin Menu, go to Settings > Permalinks and just click the Save Changes button.

  7. Increase the PHP Memory Limit of your server. Click here for more detailed information and how to increase the PHP memory limit.

If you still have problems kindly get back to us with the result of the steps above and URL/User/Pass of your WordPress dashboard using the Secure Note functionality of the post to follow up the case.

Thank you.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.