Cornerstone Error: "A conflict on front end of your site..."

I deleted each section one by one from bottom to top. I saved and reloaded the page between each one. I got the error message every time until there were only 2 sections left, but the page didn’t actually load the sections and it only displayed the “Test Page” title. I deleted the second section, saved, reloaded, and got the error message with only one section left undeleted. This section is not causing the issue because when I delete just this section, the error message still comes up.

I should note that I update this page at least every couple of months and have never gotten this error message until the cornerstone update.

Hi There,

Upon investigating this issue further, I see that your PHP Max Script Execute Time is set to 30. Is it possible to contact your hosting provider and ask them to increase it to 300 (If they don’t allow such high value, 120 also should be okay). Then test your issue again.

Also I have updated your X theme & Cornerstone so that you will see improved error messages here onwards.


Increased max execute time to 300. Still have the issue.

I have realized this is happening to other pages on my site as well, not just the one I have shared in the screenshots.

I see your “improved” error message: The preview was unresponsive after loading. This is most often related to a plugin conflict or aggressive page cacheing.

We have already determined that it is not a plugin conflict or caching issue.

The error message pops up and the page loads behind the error message. I can’t get rid of the error message, so click “try again” and it reloads the page, the elements that previously loaded have disappeared, and it only displays the header and footer, as I explained and took a screen shot of before.

Please help, I’m losing money every day cornerstone is not working for me.

It would seriously help if I could close the error message without reloading the page. Add an x to the top right or something please.

Hi There,

PHP max execution time is still set to 30. Apart from that, your PHP version is v5.4.45 which also could be another issue. You can check your current server configurations by head over to Dashboard -> WP-Serverinfo.

WordPress recommends PHP v5.6.x or v7.1.x to avoid incompatibility issues ( Please contact your hosting provider with regard to this issues.

Let us know how it goes.

Can you make the error message dismissable please???

Hi There,

These improved debug messages are introduced with the new update release for Cornerstone. You can read more information from here (


Okay, I don’t think you are understanding. The page preview is LOADED behind the error message and the error message is literally blocking me from working on my site. If I can close the error message, I would be able to work on my site.

Hi There,

Sorry for the confusion here. This error message shows because the page builder is not loading or functioning correctly.

Please ask your hosting provider to update your PHP and increase PHP max execution time. That should resolve your issue.


I have been messaging my host and they said that they increased it to 300 and I explained how it is still showing up as 30s in wordpress, and they said wordpress isn’t updating it for some reason.

I don’t know why you aren’t understanding me.

Yes, the error message is popping up. I don’t know why it is coming up. But my page is LOADING. I want to DISMISS the error message, to get to the page that has loaded behind it. You need to make it dismissable with an “X” or “CLOSE” in the top right of the error message. I do not understand why you won’t consider this.

Cornerstone is so unstable.

Sometimes I don’t get the error message at all. But the page elements don’t load, only the header and footer.

Hi there,

It because of .HTML plugin, it creates inconsistency in internal URLs. I tried adding it through permalinks settings with no luck, you must not use URL with .html endpoint for now.

It loads after disabling that plugin.


I tried opening the page in cornerstone with the html plugin deactivated and I still got the error message. I’m not sure how it worked for you and not for me.

Besides, the html plugin is critical for my website and I had this plugin before cornerstone was updated and it worked just fine.

Hi there,

As you can see we did all kind of test here and gave the different suggestion that came to mind. None of them work for your environment. At last, I created a template from the 30… page and downloaded it on my local installation.

Then I imported it there and it worked with no problem! I could do edits on the page: (I added an extra s and saved the page with no issue)

This shows that there is a problem concerning the environment you installed the theme and Cornerstone in.

The last suggestion which we here offer is that you test the case by moving your WordPress installation to another server or your local machine and test the case.

That will be the ultimate test to make sure that my test was correct and the problem comes from the hosting service provider.

Thank you for your understanding.

But this was not an issue before the cornerstone update. Why do I have to move my entire website because cornerstone makes a resource intensive update? Why can’t you fix the update so it isn’t so resource intensive???

Hi @mchll9898,

What @christopher.amirian meant was you test in other environments. Cornerstone could be affected by external factors like your server configuration, caching, third party scripts, etc. But, it is not resource intensive. I’ve tested personally working with it while monitoring CPU and memory usage.

For us to know the issue comes really from Cornerstone or your host, please clear all caches and completely uninstall your caching plugins (contact the plugin developer for this). Also, deactivate all your third party plugins and customizations if you have any. Also, give us cPanel access so we could see your CPU usage for this month. I tried your WP Admin access but I get this:


I rolled back x theme and cornerstone to the last working versions and these issues are now nonexistent, so YES these issues were 100% because of the cornerstone update. NOT my host, plugins, caching, etc.

So because you are all in denial that you have ruined cornerstone, I have to work with the old versions, leaving my site more vulnerable to hacking. THANKS.

I will continue to mark this thread as unresolved until you fix it.

Hi there,

I repeat what my colleague said regarding the builder. Our builder new version is not resourced intensive. And the fact that old version is working on your environment shows nothing as the whole infrastructure is changed in the new version. There must be a setting or restriction applied to your hosting service provider which prevents our new codebase to load the preview.

Needless to say that you always have the option of the Skeleton mode whenever the preview is not loaded for a reason to do your editing:

Anyway, the fact that you refused to test the other server restricts our ability to give you more suggestions and help regarding this case.

As soon as you test the case on another server we will be happy to continue the support for this case.

Thank you for your understanding.

= the new infrastructure doesn’t work.

Read through your forum. There are so many others having the SAME EXACT issues that I am having with your new “infrastructure.” You are turning a blind eye and refusing to see that there is a problem with the new cornerstone. I shouldn’t have to move my site to a new server or a new host because of a change you made in the cornerstone plugin. That is so unreasonable to ask of your customers. Can’t you see how terrible this is??? Please, I’m begging you, go back to the old cornerstone until you have worked out the problems with the new one. I’m so tired of being a guinea pig.

Hi there,

The recent update is a major update which has large-gap from its predecessor, especially with new features. And its environment could have a different effect than the older versions. For example, let’s say operating system, we can’t reason out that Windows 10 should work on Pentium 3 Machine because it was using the same Windows, just older. It’s just a sample and a reason why you should test it first :slight_smile:

With that, it became common and one of the practice to always test major updates in a staging site (a testing one) instead of directly applying that in a live site. All maintenance, major updates, redesign, are done in a separate environment to make sure it works before pushing it live. Even by updating Wordpress core should be done in staging since a lot of plugins and themes could break, hence, if you have a stable site and currently working then please test it first in a separate environment until all issues are iron out.

Plus, we can’t stop providing updates. It’s the only way user could get a copy of it for testing and for users starting from scratch and wishes to start with the latest version.

And the fact that we’re recommending to test it in a separate environment, we acknowledged that there are issues with the recent updates and your existing environment but we’re not sure how and which. So the second step is to test it out and compare it. We’re not turning blind eye, we’re more happy to see what’s going on so we could find permanent solutions :slight_smile:

Thanks for understanding.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.