Cornerstone doesnt work

Hi there,

I’ve been having problems with Cornerstone being hugely unstable in the fact that its previews look nothing like the site in the end. Its been this way since the beginning with small things but now its even gone so far that elements have disappeared in the visual editor and I cannot get them back to edit them, they are however, visible on the site.

I’ve got a deadline tomorrow morning and this is the 4th time now that I’ve been unable to release a part of the site because Pro hasnt worked. I’m really starting to get disappointed here and I dont think I will continue to use Pro in the future, I have seldom experienced such an instable system. It’s really sad because I was so happy to have found it.

Now that I’ve got my anger out the way, what can I do to fix this? Because I need a fix FAST.

the site is, specifically the page “devsliders”, where I cannot see the modal content areas, and thus I cannot edit them.

Im working on safari or chrome on mac os 10.13., ive refreshed my caches and everything.

Hi there,

First of all, I should acknowledge that failing to have a right preview in a builder is indeed frustrating and I totally understand the pressure that you feel. Meanwhile, I want to give my word that we are here to help and do our best to make this work for you or suggest you the best solutions that we can come up with. And finally, I should thank you for providing detailed information and login credentials as it made our work easy to detect the issue.

I followed the steps below to troubleshoot the case:

  1. I went to the DevSlider page and created a template of the page in the Pro Builder. For more information regarding templates of the builder kindly read the template section of the article below:
  2. Then I added a new page called Test page and used the builder templating system to clone the same page to that tets page for testing purposes.
  3. I saw that the problem persists on that page, that showed there is a problem in the elements used in the page and not the other page settings.
  4. I found out that you have used Revolution Slider on that page, so I went to plugins menu and disabled all plugins.
  5. The preview worked normally! I understood that there is a conflict of some kind with a plugin
  6. After activating plugins one by one I found out that the Revolution Slider is causing the problem, and looking at my browser console I found out there is a problem with double jQuery library insertion problem. For more information about the browser console and the methods to troubleshoot kindly read this article:
  7. Then I went to the Revolution Slider and that specific slide which you used on the page, and clicked on the Settings icon and scrolled to the troubleshooting options and changed the options to this:
  8. That ultimately fixed the issue you are experiencing.

Besides the main problem I found out that the Revolution Slider warns about the PHP Memory Limit of your hosting service provider which I also recommend strongly that you increase as it might affect the overall functionality of the builder too:

You most probably need to contact your hosting service provider to do so, but if the provider permits you can do it manually in the WordPress. For more information:

Please be advised that there are many environmental factors involved when using a web software such our builders and themes. I strongly suggest that if you encounter problems regarding the builder check this article first:

And if you still have problems we will be always happy to be of a help as we can.

Thank you.

Hi Christopher,

Thanks for your quick response, I know you’re all here to help, and I apprechiate this.

Im really glad that this solved the issue, I was able to disable the other plugins but not the revolution sliders, because we were online and it would’ve taken the sliders off the site, how did you approach this? Or is there any way to test these sort of things without making sliders inactive on the site completely?

Second: was the problem then caused by faulty jquery in the slider? Because I did add some custom code from the support forum, perhaps I made a mistake while inserting this. Could you verify this to me?

Thanks again!

kind regards,

Kevin ten Thij

Hi there,

Point 1: Indeed, there is a challenge when it comes to troubleshooting a live website. That is why we recommend that you have the clone of your website in a staging environment and also make sure that you have the complete backup of your website before any kind of change in the site ranging from simple edits to updating the whole theme or the WordPress.

Here is a good article on how to move a WordPress website:

There are also series of plugins regarding this which you can consider using but none of them is our official recommendation, we recommend the article I mentioned above:

Point 2: I could not find the reason why that happened, and yes it might be that. The ultimate test will be to have the staging website, turning off the jQuery conflict measures of the Revolution slider, deleting the custom code you have mentioned temporarily and check the case. Unfortunately, that process again will need the sliders be unavailable for a time period to test, so I strongly recommend the point 1 solution to test this case.

Thank you.

Hi Christopher,

Thanks a lot for your hints, I will look at it!

I just ran into two other issues that I would like to as your advice for.

  1. My modal content window on the doesnt size to a mobile screen, it just sets off a distance from the top left corner and runs off the screen in desktop size. Can I adjust this somehow? The size of the modal window is now 70%.

  2. When I place words in headlines that are longer than the collumn becomes on mobile, it doesnt hyphenate the word, I thought putting the text size in “em’s” would make it scale proportionally and solve my issue but the textsize keeps being unrelated to the collumn its in, or the size of the page. Thats why it sometimes overflows outside of the yellow area’s. Can I fix this somehow?

Hey @kevintenthij,

1.) This page does not exist. Please check.

2.) Sounds like you’re using the Stepped setup and not Scaling. Here’s a demo of the Scaling setup.

If you wish to continue with the Stepped setup, you need to configure each font size per screen width depending on your design.


Oh I’m sorry! its supposed to be

Thanks for you advice on scaling! I’m going to read into it asap!

I checked the page and there’s no problem on mobile.

Would you mind providing a screenshot? Also, I’d recommend that you open a separate thread for this to avoid confusion as your original topic is related to Cornerstone not working. Post a link to this thread for reference.


Thanks! I did that now. But I’ve still got the problem with cornerstone on another page after I’ve turned both used sliders on jquery conflict avoidance. And I’ve looked closer but I actually dont think I used extra css or jquery. Do you have any idea how I could restore the preview?

Hello There,

I can see the issue. Please go to Pro > Overview and then validate your copy of Pro theme first.

Hi there,

Yea that license problem has been happening as well, should be solved now through another party. But the problem still persists, I’ve got a deadline tomorrow evening and haven’t been able to work on this site at all. I really hope you can help me out here…

Hey @kevintenthij

Everything in Cornerstone preview displays fine on my end except the sliders.

It looks that way in my screenshot because in Slider Revolution > Global Settings, I enabled Include RevSlider libraries globally and also Insert JavaScript Into Footer

I’m not yet sure why this happens in your site. I tested this kind of setup in my test site but this doesn’t happen so it could not be a bug. Would you mind uninstalling Slider Revolution then install it again via Pro > Overview?


Hi Christian,

When you say: “It looks that way in my screenshot because…” Do you mean, the revsliders dont appear because… or do you mean, the preview looks okay again because…

This is incredible, two hours ago it looked like shit and I didnt change anything. I could reinstall it but the site is currently live, can I download all the revsliders content before reinstalling it? In that case I could give it a new try during the nighttime.

I have to say, I did install it through overview the first time as well.

Hi There,

Please do the following.

Access your site via FTP

Remove RevSlider from Wp-Content/Plugins/revslider

And re-install it on Wp Admin > X >

You won´t lose your sliders as their are stored on the database not on the plugin folder.

Let us know how it goes.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.