Cornerstone doesn't work and how to edit wp-config.php

The preview Panel in Cornerstone doesn’t work. I just see a blank space on my blog and can’t see the sections I added. I already read some other topics which are similar to my problem. I know that I have to add some lines in my wp-config.php. I found this file but don’t know how to edit it. I tried to download it and edit it in my text editor (Brackets) and after that I uploaded it again. But the file which I edited can’t be uploaded so I don’t know what to do. I also read somewhere that there’s a wp-config-sample.php but I can’t find it.

Hey @Vay,

The blog page is not editable by Cornerstone because it is not a post type. There’s nothing to add in wp-config.php to allow the blog page to be editable by Cornerstone. If you need some content to show along with your post listing, you will need to build a regular page in Cornerstone and use The Grid plugin to display your post listing.


It’s the Homepage which I want to edit

Hi there,

Please provide your site’s URL and admin login credentials in a secure note and we’ll have check it. A home page can be a blog page too, it depends on your setting.

And you can edit your site’s with FTP client and any text editor, or use your hosting’s file manager and edit it.


Hello There,

I have logged in and I was able to edit your page:

Please be advised that you cannot use Cornerstone to edit your blog index, archive pages or any page using the Layout - Portfolio page template.

Hope this helps.

When I try to edit it it looks like this

In tht third Picture I added a button but you can’t see the button in the preview panel
In the second Picture I can’t even see the blue boxes where you add Elements in. Sometimes i see it sometimes not.
Hope you can help me again :sweat:

Hi there,

Could you try it on another browser? I checked and it works on my end, I also added a button which also works okay.


I tried it on Chrome and Microsoft edge on my Laptop. No changes
But after that I tried it on my brother’s computer and there it worked. I think my laptop is the problem. I read somewhere that it may have something to do with Internet Speed or something like that. Is it like that? if yes, can I do something about it on my laptop?

Hi there,

Unfortunately, that is something that we cannot give a concrete advice on because it involves the machine you are using and not the theme.

It would be possible that you might need to upgrade the unit that you are using at the moment.

Okay. Thanks for all the help