Cornerstone doesn't load with new posts

Hi there,

I’m having problems with cornerstone in all my websites. When I’m going to edit a page/post that exists it takes me to the Cornerstone screen but it doesn’t show all the elements that I have in the page.

If I’m going to create a new page/post, it doesn’t load Cornerstone. It makes as if it’s thinking and then takes me back to the regular Wordpress post editor, so it never takes me to Cornerstone.

It happens the same way with three websites that I have.

I use Integrity and Renew

Thank you for your help


Hey Miguel,

Please check for the following first:

  1. Ensure everything is up to date according to our version compatibility list at Please follow the best practices when updating your theme and plugins. See for more details.

  2. Clear all caches including browser cache then deactivate your caching plugins and other optimization plugins.

  3. If you’re using a CDN, please clear the CDN’s cache and disable optimization services.

  4. Test for a plugin conflict. You can do this by deactivating all third party plugins, and seeing if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.

  5. Remove custom CSS, Javascript and templates.

  6. Reset your htaccess file by renaming it to .htaccess-bak. Then in WP Admin Menu, go to Settings > Permalinks and just click the Save Changes button.

  7. Contact your host to increase your allocated memory or do it yourself by adding this code in your wp-config.php

define( 'WP_MEMORY_LIMIT', '256M' );
define( 'WP_MAX_MEMORY_LIMIT', '512M' );

Let us know how it goes.


Thanks for your suggestions. I tried all of them and none worked. However, I found that in the list of Version Compatibility the version that you have of Cornerstone is 2.1.5 and I have installed 2.1.7. How is that possible?

I thought that it was a problem with my computer but I tried with my tablet and it’s the same. Tried with different browsers and nothing.

Appreciate your help,

Hi Miguel,

Sorry for the confusion, you actually got the latest version of Cornerstone (2.1.7) and X (5.2.5). Did you try clearing your caching plugin? And please do a testing for a plugin conflict. You can do this by deactivating all third party plugins, and seeing if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.

If nothing works, please provide us the site URL and login credentials in a secure note so we can take a closer look.


Hi there,

I can reproduce this issue but random, it works while reloading then the issues back later. Some say it’s due to the recent updates, but the recent update only contains fixes for videos in which 4.9 has issues. In short, the 1.2.7 is basically the same as the previous version.

I noticed the same in my installation getting time-out with 1.2.7/2.1.7 using WP 4.9, but I’m not getting any issue with 1.2.7/2.1.7 using WP 4.8.3. Which makes me think, 4.9 is causing conflict and issues with the current builder. How about downgrading your Wordpress to 4.8.3 and let’s check that?



I downgraded one of my websites to Wordpress 4.8.3 and the problem still remains.


Would you mind clearing all caches again then completely uninstall WP Fastest Cache. Contact the plugin provider to learn how to completely uninstall it because it most caching plugins leaves settings that can cause issues. After that, please give us FTP access.


I have deleted all the cache in all the ways I know. Browser cache, Wordpress cache and hosting cache, several times. I uninstalled the WP Fastest Cache and the W3 Total Cache. I downgraded the Wordpress version to 4.8.3. I checked plugin conflicts. Nothing works so far.

I use X Theme in 4 websites and I have never had problems. I have another website that I haven’t updated Wordpress nor X or Cornerstone and it works perfect but in the other three websites that I have updated X and Cornerstone is not working. Am I the only one having this problem?

I’m giving the FTP info in a secure note.

Thanks for your help,

Hello There,

I have logged in and I was able to create a page in two of your sites. You can check it out in the secure note. In one other site, I am not able to because of the error:
I am getting this error when I tried to save:
http://www.hxmnxs-crxstxxnxs.cxm/cornerstone-endpoint 500 (Internal Server Error)

This could be related to security. Please contact your hosting provider and see if they can disable the security or exclude that URL and all requests (all payload related to that URL ) from your security rules.

Please let us know how it goes.


I was able to create a page in those two sites, but in both cases I have to put a title and then save the post. After that I’m able to edit the page/post in Cornerstone. It wasn’t like that before, but at least it works that way now.

When I try to do the same in the third website (himnos cristianos) it doesn’t work, it takes me to Cornerstone front end but it doesn’t show anything. It doesn’t seem to be the same problem that you are getting.

Now, what do you mean to disable the security for my website? Is this just to test if that is the problem? Is that going to leave my website vulnerable?


Hello @rmma85,

Thanks for updating the thread.

Basically what that error message tells us is that there’s something in your system preventing cornerstone-endpoint from loading thereby blocking Cornerstone from saving/functioning correctly. Please get in touch with your host and they should be able to whitelist the Cornerstone endpoint and get this working. Excluding the endpoint URL have any issues with the website security.



I did talk to my host and they fixed the third website. Now they are all working!

Thank you very much for all your help and for your quick replies.


Hello Miguel,

Glad to know the issues were solved :slight_smile:

Best regards.

Hi Team -

We are having a similar issue with a client of ours, and we have tried all of the above suggestion except the URL one with the host.

Can you please elaborate on this slightly? What end-point URL needs exclusion?


Hi there,

We totally understand that the symptoms of the case might be the same but we urge you to open up a separate thread, give us detailed information about the problem you are experiencing and give us the login credentials using the Secure Note functionality of the post to follow up.

That way we can be much more focused on the problem you are experiencing.

Thank you for your understanding.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.