Convert Plus Not working on site

We are using Convert Plus on our website and none of the widgets for Convert Plus are working.

And, no error messages that we can see.

How can we debug this?


Hey Grant,

Is ConvertPlus not working both in the frontend and backend? Please give us a more context so maybe we could provide a specific solution. While waiting for more details, please try this list of debugging steps for this issue.

  1. Ensure everything is up to date according to our version compatibility list at Please follow the best practices when updating your theme and plugins. See for more details.

  2. If you’re using a caching plugin, clear all caches then temporarily deactivate your caching plugin and other optimization plugins.

  3. If you’re using a CDN, please clear the CDN’s cache and temporarily disable optimization services.

  4. Test for a plugin conflict. You can do this by deactivating all third party plugins, and seeing if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.

  5. If you’re using a child theme, switch to the parent theme. This test will quickly tell you if code in your child theme is causing the issue.

  6. Temporarily remove custom codes you’ve added to your site.

  7. Contact your host to increase your allocated memory or do it yourself by adding this code in your wp-config.php

define( 'WP_MEMORY_LIMIT', '256M' );
define( 'WP_MAX_MEMORY_LIMIT', '512M' );

If nothing helps, please give us the following information in a Secure Note.

  • WordPress Login URL if you’ve changed the default
  • Admin Level WP Username and Password


Thanks for the feedback. It appears, and this is something new, that in the Plugins/Convert Plus, it displays that we need to purchase a license. So, when we click on the purchase, it doesn’t recognize that Convert Plus is part of the x-theme package.

This may be part of the issue we are having. And it appears to be something new that we haven’t seen before.

How can we resolve this?


Hi Grant,

Please provide the login credentials as requested above and we’ll check, and provide the URL where the widget should appear.

And all bundled plugins are functional even without buying the license. The one you’re seeing is from the plugin author, that if you buy one, you’ll able to contact them directly and provide updates instead of us. It shouldn’t be the reason why it’s not working.


Thanks, The credentials are in the secure note.

Hi Grant,

Editing the ConvertPlus forms aren’t working on my end either. It seems there is something broken, have you migrated this site? Because jetpack is complaining about Safe Mode. Could you try fixing it first and we’ll continue checking?

Or have you recently upgrade it from a very old version?


We migrated the site yesterday due to being locked out. And, at that time we re-activated jetpack as it was in safe mode.

Not sure why it reset. But we just did it again now. And the Purchase link for Convert Plus went away.

However, Convert Plus still not working.

Hello Grant,

Can you please resolve the two critical issue in the secure note first?

Thank you.

Hey Grant,

The post reply was withdrawn.
Is your issue resolved already?

Meanwhile, please make sure that you resolve this issue:

The REST API request failed due to an error.
Error: [] cURL error 28: Operation timed out after 10000 milliseconds with 0 bytes received

You may need to contact your hosting provider for further assistance.

Kindly let us know.

I am trying to figure out how to fix it. No idea what this is and how to fix.

So I have to research.

We started Jetpack again, must be the 4th time. Hopefully it works this time.

Hi Grant,

Perhaps these links might help:


I will have to contact Godaddy on Monday as they usually take hours to figure out the simplest of things.

And, I am not sure what it even means. The only things we have changed at Godaddy is pointing to the new IP address, and we have done that many times. So, not sure if this is even a GoDaddy issue.

Also, removed all unused plugins as well.

Great! Please let us know how it goes then.

Found the critical error issue. In our development site we turned off all plugins, except for Cornerstone and the Woocommerce.

And one by one turned them back on. The critical error is from a plugin called Check Email by Chris Taylor.

Then made the change in the production site and the critical errors are gone.

Convert Plus still not working, but at least the critical errors are fixed.

We will work on the not critical errors as well. Can you see what might be happening with Convert Plus now that the critical errors are fixed.

And, we are now seeing again the Activate license for Convert Plus.

And while cleaning up the site it said to remove unused themes. Did that. Now it says we should have a default theme.


Hey Grant,

I logged in to your live site and first, I saw errors in the console coming from Jetpack so I deactivated it temporarily. I then opened the Modal Popup Designer and it loads indefinitely but there’s no error in the console. Because there’s no error that could lead me to know the cause. I activated Jetpack again after testing.

Indefinite loading of Ajax powered pages like the Modal Designer is usually caused by limitations in the server though.

I installed the WP Server Info plugin in your site so I could see some PHP/Server setup and I saw that have 256 M of Memory Limit. If you have followed the previous instruction to increase the memory, that is good as that usually fixes most issues. Your site might be needing more. Please contact your host again to increase the memory to 512 M. This time also, ask your host to increase the Max Execution Time. Right now, you’re limit is 120s. Please ask your host to increase it to 5 minutes or more.

If that doesn’t help, please also provide us with FTP access. You can ask your web host where to find that info if you’re not familiar with FTP.

Please also give us WordPress Admin and FTP access to your staging site. Troubleshooting in a staging site is in fact the best practice so your live site is safe.

If you can though, I’d recommend that you try setting up a website in other hosts just to see if they don’t have compatiblity issues with ConvertPlus or they can run ConvertPlus without problems. If there are no errors in the console, it’s mostly server limitations that are causing issues in a site.


Thanks for all the feedback. Greatly appreciated.

The secure note has our login information to the development site.

Somewhat reluctant to make changes to the host without more investigation. i.e. there was a fairly simple fix to the critical errors by removing one plugin. I think we need to investigate more the issue before making host changes.

We also just found out that Convert Plus uses Google ReCaptcha V2 and not V3. We had v3 in there and it was working until lately. But have now updated to V2.

Thanks for all your assistance. Hopefully using the development site to trouble shoot will help.

Having spent probably 10 - 15 man hours on this, plus your time, I think I may have discovered the problem.

We were able to create a new infobar and test it in both the development environment and production.

In both cases the newly created infobar worked. So, the issue is with existing infobars and modal pop-ups.

For the infobar, the newly created infobar, before and after styling, had a theme suffix similar to this:
&theme=image_preview# The image_preview# is one of the free infobars provided by Convert Plus. Even after editing/customizing, the infobar retained the suffix for &theme

However, when looking at the URL for all the existing infobars and modals, the &theme is empty. It would appear that the link is somehow corrupted.

So, how do we recover the data used for the &theme tag. Otherwise we have to recreate everything and this is cumbersome and time consuming. And, there is no assurances that it won’t happen again.


Hey Grant,

Thanks for investigating further and figured out why the ConvertPlus editor is not working.

I’m sorry to say though that there is no way to recover the theme data. I’ve searched database entries of ConvertPlus to see if there’s a way to recover but there’s none. You would need to revert your site from a previous working state.

Another alternative is to remember what theme the Modal or Infobar was using and add it to the URL like in the screenshot below.

I’m also not sure how the theme data could have been removed. It would be best to contact the ConvertPlus author directly so you might get some more ideas because they have more knowledge of how their product works than us. You would need to purchase a standalone ConvertPlus license though. If getting direct support from ConvertPlus is not possible, we’ll post this in our issue tracker so the person responsible for reporting issues with the bundled third-party plugins will be made aware of this new case.

Thank you for understanding.

Thanks for all your help.

Unfortunately Convert Plus is a disaster. What an incredible waste of human effort.

Do you have any recommendations to replace Convert Plus?

Hello Grant,

Sorry for the inconvenience. This issue is only happening on your site. It could be because of the server limitations.
Anyways, you can check out this link for other alternatives:

Hope this helps.