Conflict on front end of site HTTPS issue

Hello, I read through some of the support forums and I see that my site is forcing ssl but my internal is not. However, I have an issue changing that. It is “locked” where I am supposed to change the links, and not letting me change that for some reason to an HTTPS address. I do not know how to get around this (I am new to this entire process) and I cannot get working until this is fixed. I do have my site in maintenance mode at the moment though. Then I need to figure out (and read more articles) on how to get a demo site up and running with my content.

If I could get help switching my internal to HTTPS and some links to understand how get going on my pages (and using VC on those) that would be great. I have login credentials on my secure note. Thank you!!!

I was able to change the HTTP to HTTPS internally and get the page to work for a little bit. New issue with page not loading due to conflict on front end of site. Also getting an error sometimes for a page conflict (red box vs. big white message) I have no idea what it is now and I have tried troubleshooting it as much as I know how. The login credentials are still active in my secure note. Please let me know if you can help me. Thank you in advance.

Please help if possible. Thanks for any reply.

For Those of you searching for https solutions (bc it doesn’t say it here bc I figured it out on my own) - I downloaded the plugin “WP File Manager” then do this: (This solution is if you cannot change the address under admin>settings>general)

If it is https issue be sure to put
before the site name so that your internal links are reading the same. That is, if you are forcing an SSL or using a plugin to do so, on your external pages but your site internally ; settings>general wp address url and site url are showing http and not https; that is what you need to fix.

Here is how to change that using wp file manager (if you cannot change it in your general settings)

-Changing the Site URL
find and choose Edit of this file ’ wp-config.php ’
Add these two lines to your wp-config.php, where “” is the correct location of your site.

(Note that these two lines are already there right at the top of this file- you are just editing these to get them to read the same)


(again, if its an https issue- just add https instead of http to the lines shown above)
That should solve your issues and they should read as the same.

Just save the file and head back into your x theme. That should solve it.

Still having trouble? Disable all your plugins (especially caching) and enable them one at a time until you know which one is causing you trouble.

This is not necessarily the best fix, it’s just hardcoding the values into the site itself. You won’t be able to edit them on the General settings page anymore when using this method. but its pretty easy to get back into it from this file manager if you need to in the future.

Hi There,

Thanks for writing in! Can you please try disabling your caching plugins and other 3rd party plugins to find the root cause of this issue.

Let us know how it goes.

All of my plugins are turned off (literally every single one) and i am still getting an error “A conflict on the front end of your site has prevented the preview from loading”. However, I am noticing that it is only happening on my woocommerce shop page and not on any of my other pages.

Also, my Visual composer plugin will no longer update since installing x pro theme.

This is the error I am getting on my shop page. Even when NO plugins are active. Thanks

Hello There,

Thanks for updating in! Please be advised that you cannot edit the Shop page in Cornerstone. Cornerstone is a live preview editor. The shop page when viewed live, WooCommerce will take over and dynamically generate the contents of the page. This is why it only happens in the Shop page. The same thing will happen to any page assigned as your Posts page or any page that uses Layout - Portfolio page template.

Hope this explains it briefly.

Thank you for that response. I will look into fixing that page because it looks terrible right now. The product images are all too large and the text is too big and its a huge mess (even though on the back end or anywhere the page is showing as blank and there is nothing on it. Not even a shortcode for products)

My Next issue however is this;

Why does X say that I can use my Visual composer that I have when I cannot find it or update it. I would like to use some of the animation features of VC but cannot seem to locate it anywhere. Or update it now that x pro has been installed.

Hello There,

Thanks for updating in!

On the shop page, you may not find any shortcode or content because once you assign a page as your shop page, WooCommerce will automatically take over and dynamically generate contents for the shop page.

To properly set up your WooCommerce shop, please check out this documentation:

If you want to use Visual Composer, you will need to install it first. Please go to Pro > Overview > Extensions and find the plugin. Once installed, you must activate the plugin and start using it. To know how we have integrated this plugin, please check this out:

Please let us know how it goes.

Thanks for this great info. Running into an update error with VC. When I try to update it, it says “Update Failed: Download failed. A valid URL was not provided”

What does this mean and how can I fix this?

Hello There,

At the moment, the latest version of VC supported in Pro theme and that is server by plugin server is only version 5.1.1. We will be the ones to give the plugin updates coursed through our plugin repository. At the moment, this is an error because the plugin update url is not yet available in our repository. To know more about the latest compatible version of the bundled plugins in Pro theme, please check it here:

Hope this helps.

Hello @RueNel and @mldarshana,

Still having issues with the shop page. I started a new thread if you would like to take a look and offer any advice on the problem. Thank you

Hello There,

Thanks for writing in! Please keep in mind that the shop page might be able to edit in Cornerstone, VC or the default WP editor. WooCommerce will completely take over the page once you have assign it as your shop page. There are things happening behind which would allow WooCommerce to generate product items and the template layout of the shop page is using the index.php, the same as the blog index.

In WooCommerce settings, you have an option to display product items or product category in your shop page. You can also display product category and product items.

To properly set up your WooCommerce shop page, please check out this documentation:

Hope this helps.

Hello @RueNel,

Thanks for the help!

So just to clarify things; I can edit the page all I want but it will not change because Woo has taken over the page as the shop page. So all I can do is change the shop page to have product categories/products on the page that you set up in the woo settings?

I cannot edit the page at all except for woo settings. I can only have the products on that page. no embedded google map, not extra text describing my services/products to people… Only whats in the woo settings?

Is this correct?

Hi there,

Yes, correct. You can’t really edit the archive pages (blog page, shop page, forum page, and all other types of index pages). Your only option is to create a custom shop page.

You may want to consult it to a developer if you wish to have a custom shop page that allows editing, cornerstone will work as long as it utilizes the editor (index pages doesn’t use the editor).