Can't Validate X Theme - tried suggestions

I’m getting the error: Could not establish connection. Please ensure your firewall is not blocking requests to

I tried &force-check=1 and that’s not working.

This is the result when I do &x-verbose=1 : array(0) {}

My host (Media Temple) says everything is good on their end.

Any suggestions?

Hi there,

Please kindly contact your hosting service provider and ask them to whitelist the cURL access to

As mentioned in the article below:

The Email can be like this:

Hello [provider],

My WordPress installation is having a hard time making outbound HTTP requests. I’m using X theme and it makes a request to for setting up automatic updates.

Could you please do the following?

Ensure my site can reach this domain:
Ensure cURL is working, and allow_url_fopen is enabled.
Ensure PHP is configured with the latest CA Root Certificates.
Check into the error message above.
Please advise on anything you discover. Thank you.

Thank you.

This is their response:

“I can confirm that our WordPress hosting comes with the requested features enabled.”

I fixed the problem by doing this: I manually updated from 4.0.4 to the latest (5.2.5) and then was able to validate.
For some reason the old version wasn’t validating, but the new version did.

Now I’m running into another problem when I try to switch from X to Pro. When I do a Live Preview or try to activate Pro I get HTTP ERROR 500. I’ll open a new thread for this.

Ok. I fixed the ERROR 500 problem by deleting the Cornerstone plugin (actually I just renamed it to test) and I was able to activate Pro.

Glad you’ve sorted it out :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.