Can't select certain elements on Cornerstone after updating

Hello guys,

After I updated to the last X Theme and Cornerstone, there are certain elements I simply cannot select while in the Cornerstone edit page. For instance, if I add a classic embedded video element and add the Wordpress code:

[embed]Video link here[/embed]

It’ll work, but I can’t select the element anymore: when I hover the video, the Cornerstone blue element frame will show up around it, but clicking will only result in the video playing. Another example is that, if I add a Raw Content with the following code

[track]<a href="link"><button>Hello</button></a>[/track]

I will also not be able to select the element, as clicking on it will simply click the button and redirect me to its link. Just so you guys know, the [track] shortcode is one created by myself so we could track clicks on certain buttons on the site, it simply adds a span tag with a certain ID to what’s inside of it, so nothing complicated that could break anything. Same case for [embed]: we use it to track Vimeo videos, so we can’t really use other X theme options.

Everything was working fine since the last updates, and now building pages using these elements I mentioned is very uncomfortable, as I have to use Cornerstone’s Grid view to select the elements, and sometimes it can be quite hard to tell what’s what there.

Could you guys help me out? I feel like it could be a z-index issue of Cornerstone selectors, as the frame of the element still shows with mouse hover.

Thank you!

Hello @jcarnasciali,

Thanks for asking. :slight_smile:

Please follow up the steps below:

  1. Ensure everything is up to date according to our version compatibility list here. Please follow the best practices when updating your theme and plugins. Click here for more information.
  2. Go to X > Settings and click on the Clear Style Cache button.
  3. If you’re using a CDN, please clear the CDN’s cache and disable optimization services.
  4. Test for a plugin conflict. You can do this by deactivating all third-party plugins, and see if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.
  5. Remove custom CSS and Javascript from the options or Child Theme and test the case.
  6. Reset your htaccess file by renaming it to .htaccess-bak. Then in WP Admin Menu, go to Settings > Permalinks and just click the Save Changes button.
  7. Increase the PHP Memory Limit of your server. Click here for more detailed information and how to increase the PHP memory limit.

If you still have problems kindly get back to us with the result of the steps above and URL/User/Pass of your WordPress dashboard using the Secure Note functionality of the post to follow up the case.

Thank you.

Hello @Prasant, how are you?

I tried most of the steps you listed above, to no avail. I also tested using the shortcode [embed] on other sites that use X and Cornerstone and have nothing to do one with the other, and all of them have the same problem. I cleared Cache, removed CSS, changed the .htaccess file, and changed the Memory Limit. All plugins are updated.

Below I’ll list the Username and Password of one of the most simple sites, a onepage in which I used only custom CSS on customize with raw content and very few plugins, and I still have the same problem.

The site is in portuguese, but I think there’s nothing really troublesome for you guys to get lost in (Pages is “Paginas”). In the homepage, third section, I have a Vimeo video. Inside Cornerstone, you can see that it’s almost impossible to select the Embedded Video element of this video: clicking on it just plays the video.

Thank you!

Hey @jcarnasciali,

I have replicated the issue in my test site. For now, please whenever you work in your page, please add this code in your Content CSS but remove it when you save your page.

iframe {
  z-index: -1

Alternatively, you can use the V2 Video element which does not have this issue.

I’ll post this in our issue tracker so our development team would be made aware and so they might include a fix in one of the succeeding releases.


Hello @christian_y,

Perfect, the z-index trick on Content CSS works very well, thank you!

I did test the V2 Video element, but unfortunately the [embed] shortcode doesn’t work on it, and I really need it on one specific site.

Also, thank you for posting it on the issue tracker. Would be a great help if this little problem could be solved on future versions of Cornerstone.


You’re most welcome!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.