Can't save to database

Excuse me,
When I modify the content and update in any page. display “Uh oh! Content failed to save” messages.
The browser console display can’t update the to database. Please kindly help me.

Hi Steve,

Thanks for writing in and the details!
Can you please check this following troubleshooting first.

  1. Ensure everything is up to date according to our version compatibility list at Please follow the best practices when updating your theme and plugins. See for more details.
  2. Clear all caches including browser cache then deactivate your caching plugins and other optimization plugins.
  3. If you’re using a CDN, please clear the CDN’s cache and disable optimization services.
  4. Test for a plugin conflict. You can do this by deactivating all third party plugins, and seeing if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.
  5. Remove custom CSS, Javascript and templates.
  6. Reset your htaccess file by renaming it to .htaccess-bak. Then in WP Admin Menu, go to Settings > Permalinks and just click the Save Changes button.
  7. Contact your host to increase your allocated memory or do it yourself by adding this code in your wp-config.php
    define( 'WP_MEMORY_LIMIT', '256M' ); define( 'WP_MAX_MEMORY_LIMIT', '512M' );
    If you could please try the above and if you still have the issue we’d be more than happy to assist.

I had checked follow above. But still have the same problems.

  1. I sure the latest version for theme and plugins.
    2.I clear the cache in the settings many times.
    3.I didn’t use CDN.
    4.I tried stop all the third party plugins.
    5.No change for Custom CSS and Javascript and templates.
    6.I tired.
    7.I has added in wp-config.php.

Hello Steve,

Thanks for updating the thread.

I logged into the website and can see the problem of content not saving. I request you to please try increase the memory to 512mb.

define( 'WP_MEMORY_LIMIT', '512M' );
define( 'WP_MAX_MEMORY_LIMIT', '512M' );

Let us know how it goes.


Thanks for reply. I has increase the memory to 512mb. I increase below in the wp-config.php and adjust php.ini.
define( ‘WP_MEMORY_LIMIT’, ‘512M’ );
define( ‘WP_MAX_MEMORY_LIMIT’, ‘512M’ );

Hey Steve,

I’ve investigated but I could not trace what’s causing issue because it’s to the database which we don’t have access and control over Some data might have been corrupted.

The issue is not with Pro because your page couldn’t really be saved even just changing the page template in the WordPress editor.

I’ve saved your page as a template and loaded it in a test page and it’s saving just fine (see secure note) so nothing in the content is causing the issue.

The solution, though I understand would require work, would be to save the corrupted pages as a template and then delete them. You will then create a new page for each and load the corresponding templates. In case you’re not aware yet, please see the Template Manager documentation to learn how to save your page as a template.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.