Can't insert a link in 'Text' element of Pro

I am having issues inserting multiple links in the text editor element. Essentially I highlight the text I want to link, search for the page in the popup that shows, and then click on the page I want. This is where the problem begins. As soon as I click on the page I want to link, the editor screen closes and I return to the settings for the text element.

When I go back into the text, it will have inserted a link like so…

<a href="_wp_link_placeholder" data-wplink-edit="true" style="outline: none;">text here</a>

And not a legitimate link. If I try to add another link the placeholder text moves to the new one, but still no real link.

Now I can edit the link in the code part of the editor no problems, but I can’t hand it off to a client like that.

Hi Vicki,

I have just tried this on my local setup and I am able to replicate the behavior that you mentioned that the text editor closes after selecting a page to link. However, the link is added correctly in the text.

Please double check that you have everything updated to the latest version. If the issue persists, try testing for a plugin conflict. You can do this by deactivating all third party plugins, and seeing if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.

For now, I have reported the text editor closing and added it to our issue tracker so that our developers will be aware of it.

Thank you.

I have deactivated every plugin, but unfortunately the problem is still there.

If I use Firefox rather than Chrome it will insert the link, but the editor still closes.

And another issue is if I try to add in more than one link, only one of them stays linked.

Hi Vicki,

In that case, please provide us your wordpress admin login in Secure Note so we can take a closer look.

Note added above.

I can add the links by using the code editor, just not by highlighting them etc which I need for this to work for my client.


Hi Vicki,

Thank you for the credentials but it did not work.

Same as Jade, I got the closing of the text editor after I clicked the page to link to, but I get the correct page link not the _wp_link_placeholder

You said it works in Firefox, would you mind trying in Incognito mode of Chrome where there is no Caching and Add-ons involve.

Let us know how it goes,

So Chrome in incognito mode gets me to the same place that you are, which is an improvement.

It would just now be nice if the editor screen does not close.


Hi Vicki,

Yes, this has been added to our issue tracker so that our developers will be aware of it.

Thank you.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.