Can't activate child theme


I’ve just installed the X child theme, but WP won’t allow me to activate the theme.

When I click the activate button, I get redirected to the Validation Page. But I’m not sure how this should help me activating the child theme.

So, how do I proceed here?

Thank you

Hey Amanda,

Thanks for writing in.

Redirection to the validation page is normal after activating whether the parent theme or the child theme.

What is not normal is your child theme is not activated after that. I checked your site though and I see the child theme is already active. If you don’t see that in your backend or WordPress Admin, your server’s cache might be very aggressive. In that case, you’ll need to contact your web host to learn how to clear all caches in your server. Clear your browser’s cache as well.


Hi, OK thank you. I’ll contact them and see, if they have a solution.

After I installed and (apparently) activated the child theme, I’m not able to choose between the Demos. I thougt it was due to the child theme not beeing active. But since it IS active, shouldn’t I then be able to choose a demo and start working?

Or is this error also due to the cache’s need of beeing cleared?

Thanks you.

Hello Amanda,

Kindly check the version of your X and Cornerstone and make sure that both of them are updated to the latest version.

If the issue persists, there must be a plugin that is causing a Javascript issue which is stopping the admin area from functioning normal so please try testing for a plugin conflict. You can do this by deactivating all third party plugins, and seeing if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.

In case the issue persists, please provide us with the admin access to your site in a Secure Note:


Thank you.

I had the elementor plugin activated. The problem was solved by deactivating this.


Hey Amanda,

We’re glad you’re issue was resolved.

Almost :slight_smile:

Still working in the cache clearing part. I was told to use WP Super Cache, but they don’t provide support regarding this.

I’m supposed to use a permalink… But how do I choose/define the correct permalink in the WP Permalink Settings?

Hi Amanda,

You can choose any option from your permalink settings except for Plain. Plain means the URL rewrite is disabled.

Rewrites are usually supported by most hostings, if not then you’ll have to contact your hosting provider and have it enabled for your :slight_smile:


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.