Cannot save - extremely slow

Hi. I am working on this page:
The saving process takes approximately 5-10 minutes after updating the map on the page.
I have tried to disable extra plugins but I am still experiencing the same problem. I have also tried to use another template - where the saving process went so much faster. The entire site, when using another theme, is much faster.
Can you help me. As of now it is not possible to work with the site at all.


Hello Tomas,

Thanks for updating in!

I have check the page and there is a JS error:

You have included the Google Maps JavaScript API multiple times on this page. This may cause unexpected errors.
Google Maps JavaScript API warning: NoApiKeys

Related thread:

Please check your Google Map API key settings. You may have added it twice which affects the Cornerstone while saving.

Ok. I actually had used the api key twice. I removed it from the first page. Can you please check again and see if the problem is still there.

Hey Tomas,

I am still seeing the JS error. Since you have installed a caching plugin WP Fastest Cache, please clear your plugin cache before testing your site. This can cause the changes to not take place on the front end. It will eventually show up when the cache regenerates, but it’s not ideal if you’re looking to see your changes immediately. Caching plugins are best to turn on only when you’ve finished building the site.

Please let us know how it goes.

I am still experiencing problems with the page. When editing the preview in Cornerstone doesn’t open so I need to make the changes in skeleton mode. Saving takes approximately 5 minutes.
Can you help me?

Hi Tomas,
Please follow up the steps below:

  1. Ensure everything is up to date according to our version compatibility list here. Please follow the best practices when updating your theme and plugins. Click here for more information.
  2. Switch to the parent theme to check if the issue persists.
  3. Turn off all the cache plugins.
  4. Reset your htaccess file by renaming it to .htaccess-bak. Then in WP Admin Menu, go to Settings > Permalinks and just click the Save Changes button.
  5. Make sure that you’re running at least PHP v5.6.x or later to avoid any WordPress related incompatibility issues. If you’re not sure what your server configurations and settings are, install a plugin like WP-Serverinfo ( and check your server info by head over to Dashboard -> WP Serverinfo area.
  6. Check your PHP Max Execution Time and set it for 120 for optimal usage (
  7. Increase the PHP Memory Limit of your server. Click here for more detailed information and how to increase the PHP memory limit.

If you still have problems kindly get back to us with the result of the steps above and URL/User/Pass of your WordPress dashboard using the Secure Note functionality of the post to follow up the case.

Thank you.

Hi There,

The images on that page are loading very slow. It took more than 15 seconds per image:

I recommend you to reduce the size of those images OR using the CDN for all the resources.

Let us know how it goes!

I have tried to reduce the size of the files. The page seems like a little bit faster when visiting it. But, when I try to edit page in cornerstone - the "visual"cornerstone never loads - it just keep spinning. Working in skeleton mode works, but it is still extremely slow to save.
Can you help me with the “visual” cornerstone?


I also tried to edit another page and I am experiencing the same problem. The visuals doesn’t work.

Hey @TomasJarvling,

Cornerstone works on my end and saving does not take minutes. You can see the actual load time in my screencasts in the secure note.

The problem could be in your browser. There might be something conflicting with the builder’s scripts. If you’re using browser extensions, please deactivate them all and test Cornerstone again. Please also try clearing your browser cache again and also try other browsers and incognito mode.


You are right. Probably something with cache. I deactivated some other plugins also. It works better now. Thanks for the support.

Glad we were able to help :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.