Cannot edit woocommerce products anymore

Hi there

I have a big issue with my webshop. I can’t seem to edit any woocommerce products anymore. All I get is this:

Text of the product is not visible anymore, there is no more Yoast, etc…

I started using WP Rocket, WP Disable & Cloudflare since yesterday. Since this gave a lot of errors on the front side of my website when settings were too extreme, I deleted my complete website and restored from backup.

I also pauzed Cloudflare. Only thing left are the DNS nameservers still on Cloudflare (will change back to my host DNS nameservers within 24 hours) but that should not cause the issue, right?

Since restore from backup the problem is still there. When I made this backup the problem was not there.

Could you please help me resolve this issue?

Thanks in advance!

Hi @Woordenaar,

Actually, this can be a problem of the CloudFlares DNS routing as you had no problems with the theme and it started as soon as you tried to use the CloudFlare.

Here is the correct usage of the CloudFlare:

But I also suggest that after 24 hours you do the tests below:

  1. Ensure everything is up to date according to our version compatibility list here. Please follow the best practices when updating your theme and plugins. Click here for more information.
  2. Test for a plugin conflict. You can do this by deactivating all third-party plugins, and see if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.
  3. Remove custom CSS and Javascript from the options and/or Child Theme and test the case.
  4. Increase the PHP Memory Limit of your server. Click here for more detailed information and how to increase the PHP memory limit.
  5. Reset your htaccess file by renaming it to .htaccess-bak. Then in WP Admin Menu, go to Settings > Permalinks and just click the Save Changes button.

Thank you.

I already have my php memory limit at 256 MB.

I already tested with disabling plugins, although I cannot disable them all since the issue only appears on the live website. Same for custom css javascript. I rather not remove them on live website.

Issue of broken woocommerce product editor remains. This issue started not with Cloudflare & WP Rocket I think but when WPML was installed.

Issues with Cloudflare & WP Rocket are already resolved.

I disabled WP Rocket & Cloudflare. And I even changed back to my hosting provider nameservers again.

Every plugin was up to date when issue was found.

I already tried changing htaccess.

In the link to the tip on using cloudflare it states:

“it has been confirmed that minification in CloudFlare can break X Theme 5 and Pro Theme, so be sure to disable them.”

Does this also apply to minification settings in cacheing plugins like WP Total cache & WP Rocket?

I think I will restore complete site from backup again.

On the backup everything is working fine. And I’ll test on development server first before applying Cloudflare & WP Rocket again…

Hi Woordenaar,

Thank you for the information. As the last section answer, yes the minification should be turned off for the WP Total cache too as the original files of the theme are already minified and the plugin minifying them again will break the website.

I also, do recommend that you have a dev version of the website and follow ALL the steps I mentioned including disabling all plugins which currently you can not do on your live server.

Please consider that there is no such an issue reported with our theme and this is 100% a unique case for your environment which you need to find the problem cause.

Please do a simple test on the dev website by changing the theme to the default theme of the WordPress. If the problem persists then it is indeed not related to our theme.

If you find out that the problem is an incompatibility between Woocommerce and WPML you need to contact their respective support to follow up the case.

Thank you for your understanding.

Thanks for your advice :slight_smile:

HI @Woordenaar,

Let us know how it goes.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.