Cannot edit pages in Pro

Hi just installed Pro version 1.2.7 and switched from X. No longer able to edit content in Pro. Starting with a static home page created in X -> edit in Pro -> Content -> Home (edit) -> nothing.
In X, the classic Cornerstone page builder could handle editing so why not Pro?

Hi @Mbzo,

Thanks for writing in.

I could see a lot of script errors in your setup.

I have not experienced this issue in my test sites. You could try the solutions below.

  1. Clear all caches including browser cache then deactivate your caching plugins and other optimization plugins.

  2. If you’re using a CDN, please clear the CDN’s cache and disable optimization services.

  3. Test for a plugin conflict. You can do this by deactivating all third party plugins, and seeing if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.

  4. Remove custom CSS, Javascript and templates.

  5. Reset your htaccess file by renaming it to .htaccess-bak. Then in WP Admin Menu, go to Settings > Permalinks and just click the Save Changes button.

  6. Contact your host to increase your allocated memory or do it yourself by adding this code in your wp-config.php

define( 'WP_MEMORY_LIMIT', '256M' );
define( 'WP_MAX_MEMORY_LIMIT', '512M' );

Let us know how it goes.


Hi there, it would appear to be a conflict with a plugin: WPML Multilingual CMS.
According to WPML I can still use the X theme and Cornerstone to edit pages:
But not Pro?

Hello @Mbzo,

It looks like you have deactivated WPML plugin. Can you please confirm you have tried the solutions mentioned by my colleague in previous reply other then testing for plugin conflict? Also please try increasing PHP max execution time and see if that fix the problem. You can add following code in .htaccess file to increase max execution time:

php_value max_execution_time 300

I also created a test page and

Kindly let me know.


The other solutions did not have any visible effect but I did what you suggest and added that line to .htaccess
I can edit headers and footers but not page content. Disabling WPML allows me to edit page content.

Hello There,

Thanks for updating in! I have logged in again and even if WPML is disabled, I still cannot edit the page using the editor. I am seeing this (see in secure note):

Is it possible that you can give us access to your ftp so that we can investigate deeper? There might be files that were corrupted or some settings you may have added which made the conflict.

Thank you in advance.


Based on your post I am not sure if you need assistance, if you do, please let us know.

Thank you

Hi, thanks for the reply. Here are the details:

@Glasseye, please open a separate thread because thread hi jacking is not allowed. Please see How To Get Support for details. Follow the general troubleshooting guide given previously in this thread or see this article.

@Mbzo, try changing your permalink to post name and also check if WPML uses the same pretty permalink structure too.


Joao asked me if I need help so I replied, I am not hijacking anything. If this was wrong, please tell me what was the correct action to take. Thank you.

Hi @Glasseye

I was not clear and my colleague is correct. We don´t mind if someone joins the thread once the issue of the person who started the thread is resolved, otherwise, please open a new thread and explain your situation.

Thank you

Thanks. Here are the details:

Hi there,

I did spend a lot of time on your website to find out why this is happening with no success. I reinstalled the Pro, Changed the default URL of the Pro Editor, Changed the Permalinks, Added the normal .htaccess file which should work for a typical WordPress installation with no success.

The Pro Editor links to 494 page even if I disable the WPML plugin. So this is not related to the plugin and is related to the URL Rewrite rules on your server.

I suggest that you contact your hosting service provider and ask them to double check the URL reWrites for you and if needed clear any possible cache they might have internally.

Thank you.

Hi Christopher,
Greatly appreciate the time you have taken to investigate the issue.
It’s a shared Windows server. In setting up the rewrite rules I used this reference as a guide:
I will contact the hosting provider as you suggest.

Hi there,

That should be enough since all requests are rewritten and forwarded to site’s base index.php regardless of URL format. But I’m not sure how Windows forward those requests, I had bad experiences when it comes to Windows server too.

Looks like the redirect is permanent to your host environment, even by disabling almost all plugin, it still redirects to non-existing page. I recommend cloning your site into the different environment (linux) and compare them to see what’s different.

Been trying this without any success in finding the cause, I know there were some issues with WPML and the builder in some cases, but it should work once you disable them.


Thanks for the reply. Cloning the site to a Linux environment is a good idea though it should be possible on Windows. The main site has X and WPML running fine.

Hi there,

It should be working in Windows if the environment allows it. It’s the same in Linux, if there are many restrictions then it will not work as well. The only purpose of the request is for comparison since it’s harder to troubleshoot Windows environment than Linux.

I’ll continue checking, but I can’t promise any good result.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.

Hi There,

Navigating to Settings > Permalinks resolved that issue (see screenshot).

If you have additional query, please create a new thread as this one is getting long and being hard to support. And this has been closed too.

How To Get Support