Button To launch Lightbox not Working

Hi I used the following code on a classic raw element: could you advise why it can’t be launched?

[button class=“video-whatisems” style=“padding:18px 85px;” type=“flat” shape=“rounded” size=“large” href=“https://youtu.be/LYRTFpN18F0” title=“WIEMSpro - What is EMS?” lightbox_video=“true”][icon type=“play”]WHAT IS EMS?[/button]
[lightbox selector=".video-whatisems"]

Hi There,

The shortcode is correct. Would you mind sharing the URL where you implement that so we can check?

Hi Please view over here: https://wiemspro.asia/

It’s on the 2nd button called “WHAT IS EMS”


You need to use the embed url.

Please change code to this.

[button class="video-whatisems" style="padding:18px 85px;" type="flat" shape="rounded" size="large" href="https://www.youtube.com/embed/LYRTFpN18F0" title="WIEMSpro - What is EMS?" lightbox_video="true"][icon type="play"]WHAT IS EMS?[/button]
[lightbox selector=".video-whatisems"]

For more information regarding this, kindly refer to the link below

How to Find Your YouTube Embed Link

Hi Paul, It’s still not working… I have check several other sites that uses this method and it’s not working either…

Hi there.

I tried checking your site and the lightbox seems to be working fine upon clicking on the button:

Kindly try to clear your browser cache and check again.

I’ve cleared the cache. It’s not working on Chrome and Mozilla however it is working on Microsoft Edge and Chrome on Mobile. Would you be able to offer any insights into this? Thanks.

Hi there,

It’s working on my end it. What browser version you’re testing it with? And what OS?


Hi Rad,

The OS is Windows 10 Home Single Language, version 1709:

It’s not working on the following browsers:
Google Chrome, Version 62.0.3202.94 (Official Build) (64-bit)
Firefox Version 57.0.1

It’s working on:
Microsoft Edge 41.16299.15.0
Google Chrome, Version 62.0.3202.84 (Mobile version on Android 7.0.0), when I select request desktop site it is also working.

Hope these information helps.


Hey Benjamin,

I am on a MacOS and it is working in my Chrome and Firefox browser.



I think you are just having a browser caching issue. Please clear your browser cache or use private browsing mode and test your site again.

To know more how you maybe able to clear the cache, please check this out:

Hope this helps.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.