[button] shortcode does not work on Pro theme

This shortcode used to work for me.

I’m looking to create a button for my sidebar’s widget via the shortcode.

Does Pro not use X’s same shortcodes?

Hi there,

The shortcodes should work on Pro without any problem.

Kindly double check if you are adding the correct shortcode in the Text widget.

You may refer here:


In case you are still not able to make it work, kindly post the shortcode you are using here and provide us with the URL of your site.

Thank you.

Here’s a direct copy & paste of the sample code:

See it live: https://northstories.io/marketing-roi-long-term-immediate/


Try adding it in text tab instead of visual tab.


Tried it… the issue persists:

Thanks @paul.r

Hi there,

I suggest that you use the Global Block instead of the [button] shortcode. The [button] shortcode should work anyway but I think if you go to Appearance > Widgets and use the Custom HTML widget instead it will be better. Also make sure that you use the correct syntax of the button shortcode as mentioned below:

Now I suggest that you use the Global Block as you can add the new button element and style it as you wish using the same way you would do in the Cornerstone. Then you will get a shortcode that you can paste to the Custom HTML widget and have the button.

The Global Block will give you much more flexibility and you can use all the new V2 elements and not limited to the old shortcodes.

Thank you.

Thanks @ christopher.amirian

I did try this earlier and it did the job.

However, I found it quite heavy/cumbersome. For instance, the margins/paddings are built for a full width page rather than a sidebar widget.

I’d prefer to build, edit, and maintain these using universal Wordpress text widgets and shortcodes.

Is there a different shortcode for V2 elements? That would be nice. I’d like to add V2 buttons (and just the buttons themselves rather than entire widget areas)

I figured a workaround and felt smart about it…lol… Just used a Global Block with just one button then I “Removed Spaces” for the Cornerstone column…

Ok, so far so good. It should have worked…

Then I applied the Global Block shortcode… No luck:

Okay, found a workaround!

I used the “Custom HTML” WP widget rather than the “Text” widget.

There’s just one bug, though.

The button is supposed to look like this: https://cl.ly/0Q3y3k2o3R1g

It seems like the widget only shows the Hover state without the Default state… Hope this bug can be fixed soon


I can’t repicate these issues in my test sites.

Would you mind providing us with login credentials so we can take a closer look? Please provide following information:

Set it as Secure Note

  • Link to your site
  • WordPress Admin username / password

All the best!

Thanks, done adding!

I’d also like to note that even after the workarounds, there appear to be some CSS conflicts.

It appears as: https://cl.ly/2F3r3S033a2B

Instead of: https://cl.ly/1o3b2p063M0z

Hey @allancaeg,

The credentials you gave are not working. The issue though is because of Integrity’s widget text shadow.

You can eliminate it by adding this code in Theme Options > CSS.

.widget {
    text-shadow: none;

Hope that helps.

yay, thanks!

On behalf of my colleague, you’re welcome. Cheers! :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.