Burger menu doesn 't work anymore

Hi Guys !
for the website https://www.gold-headwear.com
I have an issue with our burger menu on mobile (it worked on pc). I searched on the forum but Didn’t find how to solve it.
The burger open, when you click on “custom headwear”, the sub menu opens but you cannot open the sub-sub menu : if you click on snapback, nothing happens…
Furthermore, to open sub menus you have to click on the arrows on the right. Is it possible to remove the arrows and open menus if you click on the text instead ?

Thanks a lot for advises !


Hi there,

I have checked your site and there seems to be a Javascript error that is causing the issue. Please try testing for a plugin conflict. You can do this by deactivating all third party plugins, and seeing if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.

Let us know how it goes!

Hi Jade !

Thanks for the help !

Ok so I try to deactivate all the plugin and I try on my phone (iphone 5S on chrome) but nothing change for the menu.
I waited, clear the cache on my phone but no… nothing happened

Any idea ? If you need my credentials, to check for yourself, let me know.

Hi There,

Could you please try disabling the gs-logo-slider-pro-2.0.4 plugin?

If it still doesn’t help, would you mind providing us with login credentials(by clicking on the Secure Note button at the bottom) so we can take a closer look? To do this, you can make a post with the following info:

  • Link login to your site
  • WordPress Admin username / password


Hi !
I try do deactivate the GS logo Plugin but infortunatly, it didn’t solve anything :frowning:

thx for the help !

you’ll find a secure note with the needed credentials

1 Like

Hi There @Vaisseau89

The WordPress user that you have created, does not have admin privileges to check your WordPress backend. Could you please confirm with the correct permissions.

Could you also please disable your CSS and JavaScript minifications on your caching plugin, purge server cache and re-test your issue again.


ok try with this credentiales instead : (secure note)

also, I already try deactivate CSS et JS minification (clear cache after that of course) before asking on the forum.

Hope you’ll find the issue :frowning:

Hi Kevin,

Your mobile menu works just fine on my end (https://prnt.sc/kz74rt), please clear your browser’s cache as well.

The Snapbacks menu item is not a link, it has no URL in it.

The double down arrow needs to be there, because some (most often) sub-menu are links too, it does not make sense if you open an item a sub-menu then navigate to different page in the same time.

Please clear your browser’s cache.


Hey !

The menu works fine on a PC but not on mobile phone.
If I try with F12 on chrome to emulate a phone, the menu works but IRL on my phone and every phone I tried, it doesn’t work.
Chrome and safari have the same issue on a phone.
Just to be clear : the sub menu appear but not the sub-submenu.
If you click on “custom headwear”, a sub menu appear, if you click now on “snapback”, nothing append but there is a sub sub menu that should be shown.

Ok understand for the arrows.

Thanks !

Hi Kevin,

To fix it, you can try adding the code below in Theme Options > CSS

@media(max-width:979px) {
.x-sub-toggle {
    width: 100%;
    text-align: right;
   z-index: 999999;

.x-sub-toggle>span {
    padding-right: 10px;

Hope that helps

Hi Paul,

I tried adding this CSS inside Theme Options > CSS
clear cache of website, clear mobile browser cache --> no success

I tried adding this CSS in theme > customize
clear cache again --> no success.

Thanks for trying still :slight_smile:


do you guys have the same issue if you try on your phone ? do we see the same thing ?


Hello There,

I have opened your site in an android phone and I do not have any issues.

Please use private browsing mode and test the site again.

Hi !

I tried clear cache, private mode and I even install firefox on my iphone just for trying but I have the same issue. I don’t know why it’s working for you but it isn’t on my phone screen.
For information, my screen seems to be smaler than yours, it’s a iphone 5s, may be it’s related ?

thanks guys !

Hi @Vaisseau89,

I tried it too and it works on my mobile phones (iOS and android). May I know what IOS version you’re using?


My iphone is on 11.2.2.

So I ask to 6 of my coworkers. All on Iphone 5s, 6 and 7 (no android here :frowning: ) . They all have the same issue.

Hi @Vaisseau89,

I checked your website with my iPhone SE and I could replicate the issue you are experiencing. To make sure if this is not a core theme issue I setup somehow the same case scenario on my installation using X with the same version that you have:


If you tap the first menu and the submenus using your iPhone you will see that the menu expansion works with no problem. That shows indeed there is a problem on your installation and not the theme itself.

Now it is important that we test the case in details following the steps below. But it might cause the website to go offline or view incorrectly while testing. That is why we urge you to move your website to a staging server so that our testing will not affect the live website. We suggest that you contact your hosting service provider to get a help to create a staging website.

If you are interested in doing the troubleshooting steps yourself you will need to follow this way:

  1. Ensure everything is up to date according to our version compatibility list here. Please follow the best practices when updating your theme and plugins. Click here for more information.
  2. Test for a plugin conflict. You can do this by deactivating all third-party plugins, and see if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.
  3. Remove custom CSS and Javascript from the options and/or Child Theme and test the case.
  4. If you’re using a CDN, please clear the CDN’s cache and disable optimization services. You seem to be using the CloudFlare which you need to disable so that you can test the case.
  5. Increase the PHP Memory Limit of your server. Click here for more detailed information and how to increase the PHP memory limit.

Thank you.

1 Like

Hi guys !

I gave up…

I did every thing you said Christopher, but, unfortunatly, the bug still remains. It will remain a mystery…

So I installed Wp Mobile Menu and it does the work.

Thanks you anyway for the help ! :wink:

Hi Thats for writing in!

Sorry for the issue you faced. We could investigate more to your site, but you have already installed the mobile menu, as this is a live site so we can’t perform any action anymore.
If you want us still to check on it please create one clone staging setup and give us the details so that we will look on to it.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.