Browser Issues with Font and Font Weight

Hi There!

I am making a website for a client and can’t seem to get my header font (Montserrat Bold and Extra Bold) to load across browsers. It looks great in Chrome on desktop, but in Safari, as well as Chrome on my mobile device, it shows the inherit font.

I also can’t seem to get my body font weight to register correctly. I’d like for the body font to display as “book” weight, but no matter how many times I check the settings in Pro, I keep getting a “regular” font weight. I noticed on google font’s website that the font weight for Roboto isn’t called “book”, but rather “light”. “Light” doesn’t show up as an option in Pro’s font manager in both the theme settings nor theme options. Could that be it? Or is it something else?

I’ve input my preferred fonts in both the theme options area and the theme settings area to be:
Body font: roboto; body font weight: 300 -Book
Headings font: Montserrat; headings font weight: 800 - Extra Bold

I’ve tried looking at other topics posted about this and have tried a couple of CSS suggestions with no success. I’d be more than happy to send over login credentials if needed.

Please help!


Hi Katie,

Thank you for writing in, but I can’t find that section on your site, please provide us the site URL and login credentials in a secure note so we can take a closer look.


Hi Friech!

I just uploaded a secure note. :slight_smile:

UPDATE: I’ve got good news and bad news.

The good news: I figured out how to get my fonts to show across most browsers! I forgot about Punch Fonts (duh Katie :roll_eyes:).

The bad news: I still need help. All of the fonts and weights now show up correctly except for my homepage.

What’s causing this? How do I fix it?

Hi Katie,

I see a broken request to the Google Fonts which seems to cause the Safari to fail to render the fonts and it is related to the Revolution Slider that you used: [rev_slider alias=“testimonials”]

Would you please test the case by removing the Revolution Slider from the page and see if it fixes the problem? If that is the problem cause then you need to go to the Revolution Slider settings and fix the font problem:

Thank you.

Ah! Thank you for getting to the bottom of that. It looks like I forced an italic style in the slider builder, which lead to my font families breaking on my home page.

I removed the italic feature and it’s working perfectly. Thanks again!

– Katie

You’re more than welcome, glad we could help.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.