Body fonts not being applied


Ive got a problem that the body font style (Open Sans) isnt being applied to existing text. Ive created text in Open Sans first which was fine. Then we switched to a custom font which we uploaded (Avenir) and then removed them and returned to Open Sans as the body font.

If I create brand new text, it will default to Open Sans but I cant get existing text to return to the body font. Is this a bug or is there something else I need to do?

Ive gone through the homepage and manually recreated the existing text so is fine. You’ll see the problem on all other pages.


Hello Will,

Thank you for the very detailed post information. What you are experiencing is just a caching issue since you have installed Autoptimize plugin. After doing the updates and site changes, always remember to clear all caches (if you are using Autoptimize, WP Rocket, WP SuperCache or W3 Total Cache) when updating so that the code from the latest release is always in use. This will help you to avoid any potential errors.

Please clear your browser cache too. You may use private browsing mode in testing your site to make sure that you are viewing the latest codes from the updates and not the cached version in your browser.

And lastly, you are using CloudFlare. Please login to your CloudFlare account and purge your site cache as well.

Please let us know how it goes.

Hi, Ive disabled autooptimise, cleared the browser cache and hard purged the cloudflare cache. I have no other caching plugins on this site.

Still seeing the same problem. Any other ideas?


Hello Will,

Are you using the font manager? Please keep in mind that the text elements has its own independent font settings. You must always check your font family in the text settings.

To know more about the font manager, please check this out:


    ​To assist you better with this issue, would you mind providing us the url of your site with login credentials so we can take a closer look? This is to ensure that we can provide you with a tailored answer to your situation.

To do this, you can create a secure note with the following info:
– Link to your site
– WordPress Admin username / password

To know how to create a secure note, please check this out:

Thank you.

Hey Will,

Thanks for the credentials. They work. However, the user does not have much permission in order for us to check your setup. Please give us Admin Level access.

For the meantime, please check if Open Sans is active in Theme Options.


Hi, thats updated. Please try again.

Hey Will,

I’m very sorry I forgot to say that you’re using V2 or Non-Classic elements in your pages. V2 elements only use the Font Manager. Please see more details and follow the solution in my reply in the similar case:

In summary, you need to load or setup Open Sans using the Font Manager since it’s needed by V2 elements


I have set up font manager with Open Sans and it still doesnt work. Given that Ive added you as an admin it would be more helpful if you tried it yourself and confirm it works.

Hello Will,

Please always make sure that the text elements or all of the elements you have added on the page is using the correct font family.

Setting it to “Inherit” might not properly apply the correct font especially if the parent container is using a different font family. And again, right after changing your font settings, you must always purge your site caches since you are on CloudFlare.

Hope this helps.

I’ve set this to every type of font, body, inherit, headings. I’ve also cleared the browser and CF cache. None of this works. You have admin access so surely you should be seeing the same as me.? The font manager is active and Open Sans is live.

Can you offer something else to get this to switch back to open sans?


Hello Will,

I have checked your site again and even compared the font to the actual Google font Open Sans (
This is what I am seeing:

The Open Sans font is working in your site except that in my comparison, I used a larger font in Google Font site.
Are you seeing the same?

Please let us know how it goes.


Youre seeing Open Sans on the homepage because I manually replaced existing text with a new text element which works with Open Sans. Its all the existing text on other pages that isnt converting properly.

Please look at the pricing page and look at the middle pricing column where Ive added some next text (Open Sans) with the old text.

Can you see the problem?


Hi Will,

I’ve taken a look on your page and it seems right to me. The only text that uses another font in the middle pricing column is the title and subtitle ( “Professional” - heading 4 and “(PAID BY CREDIT CARD)” - heading 6 which are using “Work Sans”) and the first line that uses “Calibri”.

Please be sure that you clear your browser cache. If the problem is thill there please send us a screenshot with one text that has this problem.

Thank You

Thanks - I can confirm this was a caching problem. Please go ahead and close this.

Thanks for your help

You’re most welcome!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.