Blog only showing one post after update

I’ve updated both cornerstone and xtheme and after the update the blog page is only showing one post to click on.

Hi Shannon,

Thank you for writing in, remember to clear all your caching features (plugin, server-side, CDN, and browser’s cache) after updating so that the code from the latest release is always in use. This will help you to avoid any potential errors.

If the issue persists, please do a testing for a plugin conflict. You can do this by deactivating all third-party plugins, and seeing if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.

Let us know how it goes,

I cleared the cache but still not showing more than one post

Hi Shannon,

I checked your site and I see you’ve enabled the FILTERABLE INDEX on the blog page, enabling the filterable index will bypass the standard output of your blog page, allowing you to specify categories to highlight. I believe you’ve not entered any category ID in the CATEGORY IDs field of the FILTERABLE INDEX option. please go to X > Theme Options > Ethos > BLOG OPTIONS > CATEGORY IDS and enter the category IDs in the field to showcase your posts ( see screenshot )

You can also turn this feature off to show a normal page.

Hope this helps!

Thank you. I turned off filterable index and it worked. However what are the numbers I use if I want to turn that back on, are they numbers I assign in categories?

Hi Shannon,

The numbers are the category ids.

Please refer to the link below for your guide on how tog et your category id


1 Like

I did that and it still only shows one blog post on the page.

Hello @Weedmama,

I have checked your sit and I can see that you have only 6 post. It is displaying on my end.

Please clear your plugin caches and clear your browser cache as well and test your site again.

I turned off the filterable index, when I turn it on it only shows one of those posts

Hello @WeedMama,

Please go to X > Theme Options > Ethos > Post Slider and make sure that you select to display “Random” or “Most Commented”. Featured might only display one single featured post in your blog.

If this does not help, please provide us access to your site so that we can check your settings and investigate the issue.

Best Regards.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.