Blank page for search results

I am am trying to use an inline search element but any search results in a blank page—no header, no results.

Please help. Thanks.

Hello Dianne,

Thanks for writing in!

I checked the website and can confirm that the search page is blank. I tried to replicate the same on mydev setup but inline search is working fine. In that regards please try out following solutions and let us know the outcome:

  1. Test for a plugin conflict. You can do this by deactivating all third-party plugins, and see if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.
  2. Increase the PHP Memory Limit of your server. Click here for more detailed information and how to increase the PHP memory limit.

If you still have problems kindly get back to us with the result of the steps above and URL/User/Pass of your WordPress dashboard using the Secure Note functionality of the post to follow up the case.

Thank you.

Hello Dianne,

Thanks for updating the thread.

I further took a look at the website and at the moment I am not able to see the problem that might be causing search result page returning blank page. Inspecting the page in dev tools is also not reflecting any error message.

In that regards please turn on WordPress debugging by adding define('WP_DEBUG', true); in wp-config.php file. Once you have added the code please reload the page and you should be able to see some information or error message. Kindly share the information or update the thread for us to take a closer look.

To add the code in wp-config.php file you will need to login using FTP software like Filezilla. To get started with Filezilla, please take a look at following resource.

If possible please also share the FTP login details in secure note.


I changed the wp-config file adding these lines:
define(‘WP_DEBUG’, true);
define(‘WP_DEBUG_LOG’, true);
define(‘WP_DEBUG_DISPLAY’, false);

However, when I refreshed the page, tried using the search function again, I did not seeing any errors logging. Tried several times.

I also tried just adding:
define(‘WP_DEBUG’, true);
define(‘WP_DEBUG_LOG’, true);

No error messages displayed then, either.

Hi Dianne,

Thanks for login details and the tests you have conducted. This is a little bit tricky but we’ll get there. We just need you to do several more tests:

  1. Can you try making X (the parent theme) as the active theme instead of it’s child theme?
  2. Now while X is active, please do a new search on Is it still showing blank?
  • if it’s no longer blank, then the issue is in your child theme.
  • If it still persists, try the next step below.
  1. Please activate another theme. The Twenty Nineteen would be a good candidate. Then do another search. For ease, you can use the default Admin Toolbar Search to do a search.

If it doesn’t return a blank page search results page, then the issue is with the copy of X you have installed. So to fix that, you need to reinstall X. Here are the steps:

  1. Download X from your Apex Dashboard.
  2. Once done, go to WP Admin > Themes. While Twenty Nineteen is still active, Delete the X theme.
  3. After deleting, Add a new theme and upload the X theme you just downloaded.
  4. Next, Activate.

Try if the search issue still persists. If it fixes it, try activating the X child theme again.

If none of these worked, we’d appreciate if you share with us your FTP details.

DO NOTE: that it’s recommended to conduct the tests suggested above in a staging site so no interruptions will occur on your live site.

This was the solution. The search function works now that I have replaced the parent and child themes. I migrated the site in the spring and perhaps the themes and/or database connection was corrupted in some way at that time. Thank you!

Hey Dianne,

Yes during the migration process some files might got corrupted, replacing the parent and child themes fixed the issue. Just for a future reference you can follow this tutorial for migration,

Cheers! .

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.