'App' Expanded Demo Won't Finish Setup

Hey there,

I can setup every single other demo except the ‘App’ one, including all the expanded demos and the standard ones. I followed the support articles for setting up demos, including the infamous https://theme.co/apex/forum/t/setup-demo-content/56 page that many people are being directed to, and tried all the suggestions to no avail. When I go to set up this demo, it pauses on the “Working on it…” screen for a while and then kicks back to the “Initializing” screen. I tried clearing the cache and that seemed to allow for a bit more progress but then it gets stuck on that same screen again.

I’m not sure what the issue is considering this is the only demo that won’t load.

Please help. :slight_smile:

Hi SermonVeiw,

The demo content installation problem is usually because of the hosting service provider restrictions. It might cause by several reasons that I will list below:

  1. Make sure that you have the PHP maximum execution time of 300 or above. For more information:
  2. Make sure that you increase the PHP memory limit. For more information:
  3. Ensure my site can reach this domain: community.theme.co
  4. Ensure cURL is working, and allow_url_fopen is enabled.
  5. Ensure PHP is configured with the latest CA Root Certificates.

For all the point above you need to contact your hosting service provider to follow up.

As a final resort, you can move the WordPress installation to your local machine and follow with the demo import process and then move it back to the server.

Needless to say that it is not recommended that you import demo content into an existing website as it will override many options and you might miss configurations. Try the demo import process on a clean install of the theme and WordPress.

It’s still not working. I can setup every single other demo except this one. Is there a zip I can download and upload myself?

Hi @SermonViewMarketing,

Regretfully there is no zip for it. I just imported the APP demo on one of my dev-sites and it imported just fine.

Please review Christopher’s reply above and make sure your site conform with it.

If the issue persists, please provide us login credentials in a secure note.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.