All menu items active on load with one page nav

I have one page navigation set up with my menu but on page load all items have the “current-menu-item” therefore having all of them underlined instead of just “Home”. The one page navigation works correctly except for that and also that once you scroll down and back up nothing is highlighted. Thanks for any help.

Hello Brandon,

Thanks for writing in!

To set up a one page navigation, you’ll need to set up two separate menus. One will be assigned as your primary menu and the second menu will be for the one page navigation menu. In the second menu, you can use the relative #about url of the menu item.

To know more about how you can do this, please check this out:

We would love to know if this has worked for you. Thank you.

Thanks for the reply, I created a second menu specifically for the one page nav however that did not fix the issue with all the links being “active” on load and also none being selected when you scroll down and back up to the very top.

Hi Brandon,

You need to assign that second menu as your onepage menu. When editing your homepage, you can set it from here.

Hope this helps

Yes I had done so through the dashboard already, and shows the same in the settings of x theme, but the issue still persists.

Hi Brandon,

In your onepage menu, did you change the links to be just ids as instructed by my colleague?

I checked the links and can see full urls

Please change it to just ids.


Sorry must have missed that. Makes sense since it’s a dedicated one page menu now since I created the primary menu. However this still did not seem to fix the issue.

Hi Brandon,

I checked and they are no longer active upon load, and each menu are now changing its status to active once scroll to its sections. Would you mind providing a video recording of what you’re getting? Or are you now referring to other pages where primary menu is active? Please note that you don’t have to set your one page navigation as primary menu.


What I was referring to was that home was not selected when the page loads (nothing was selected). I fixed this by adding a class to the home link and with some jquery checked if the scrollTop==0 then add a class to make it active. Thanks for your help!

Glad you have fixed this Brandon. Thank you for sharing the solution!


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.