Again having Space Issues With X theme

Hi, I have the spacing issues again after a few months using X. I tried to disable all plugins including child theme but didn’t work. Any suggestions, please?

Hello Viliam,

Thanks for writing in! I have checked your site and it seems that Cornerstone is not installed or has been deactivated. Please go to X > Validation, wait for a few seconds so that Cornerstone will be automatically installed in the background and have it activated. The X theme needs Cornerstone to run most of the features of the theme.

Hope this helps. Please let us know how it goes.

In that time, I made some tweaks and also deactivated the corner for a while… but then I activated it back and still the same issue

Anyway, I had problem to open the Cornerstone customizer, so I disabled all the plugins there, and kept only this one… then it opened the Customizer with ease, but what exactly I have to find and tweak there? Something in “Typography” or somewhere else? Thanks

Hi Viliam,

Is that the site you’re working on below? Please update to the latest version of Wordpress

Updating WordPress

Remember to clear all your caching features (plugin, server-side, CDN, and browser’s cache) after updating so that the code from the latest release is always in use. This will help you to avoid any potential errors.

I also see that the site is under Cloudflare, please Purge Everything directly from your Cloudflare account dashboard.

Purging cached resources from Cloudflare

If the issue persists, please provide us login credentials in a secure note so we can take a closer look.


I did, please check it

Hi Viliam,

Thank you for the credentials, but what is your login page? I tried /wp-admin and /wp-login.php but that just redirects me back to homepage.

And have you Purge your Cloudflare caching? If not, please do so, and try turning off the JavaScript minification feature.

How do I minify HTML, CSS, and JavaScript to optimize my site?

Hope it helps,

check my latest secure note, it’s updated so you can look at it closer

Hello Viliam,

Thanks for updating in! I have logged in and check your site. I do not see any spacing issues. Can you please give further clarifications as to what is this issue about?

Please see the secure note.

There ARE spacing issues when you open the post. It doesn’t look so obvious (as the gap between rows isn’t big, but there is double spacing)

just open any article there and you will see bigger gap betwee paragraphs

this is definitely double spacing x)

Hello Viliam,

By default, the bottom margin of every paragraph is 2.15em. It has been set in the theme’s stack style.css with this:

p {
    margin: 0 0 2.15em;

You can override this by simply adding the following CSS code in the X > Theme Options > Global CSS (

p {
    margin-bottom: 1em;

Hope this helps.

exactly what i needed, perfect… I totally forgot these css codes

Glad this is now sorted our for you Viliam!

In case you have another inquiry, it would be recommended to open a new thread instead. Thank you.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.