Activation problem PRO

I've bought an X license and updated to PRO, but when I try to validate it this error comes up:


Uh oh, we couldn't check if this license was valid. Details.

cURL error 7: Failed to connect to theme.co port 443: Connection refused


I've already contact to my server support, and they told me that everything is working fine. Could you help me solving this?

Thank You.

Hey @lucaslorenze,

Have troubleshooted the issue as mentioned in following URL https://theme.co/apex/forum/t/troubleshooting-validation-connection-issues/201?

Would you mind providing us with login credentials so we can take a closer look? Please provide following information(Use Secure Note):

  • Link to your site
  • WordPress Admin username / password
  • FTP credentials

All the best!

Ok, here goes the info

Hi,

Sorry for not asking this the first time.

Please provide us your Purchase Code as well in Secure Note

Can you also confirm that you have contacted your host regarding these

-Ensure my site can reach this domain: community.theme.co
-Ensure cURL is working, and allow_url_fopen is enabled.
-Ensure PHP is configured with the latest CA Root Certificates.

Thanks

Hi!

I've talked to my host and they said everything was working fine. I'll ask again.

Here goes the info

Hi there,

Is your site behind a security firewall? The Connection refused could means your site is unable to contact our server. It's either it's your firewall that's blocking it, or our server blocking your site's request.

I like to check where the problem lies, but I'm unable to connect or resolve to your FTP. Maybe your site's security firewall is blocking FTP access too? Plus, you didn't provide FTP password. Please provide more information about how we can connect to your site's FTP.

Thanks!

Thanks for the answer.

No, my site is not behind a firewall.

Hey There,

I've taken a close look at this and your hosting provider is blocking the outgoing conection:

"cURL error 7: Failed to connect to theme.co port 443: Connection refused"

You will need to get in touch with them and make sure that cURL is enabled and allowed to connect to our validation servers.

Ask them to try a cURL to 34.199.208.181 which is our server IP.

If you need any help on the way let us know!